{"id":"GHSA-gm4m-9rm8-7rxj","aliases":["CVE-2022-35692"],"title":"Magento Open Source has Improper Access Control vulnerability","description":"Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to leak minor information of another user's account details. Exploitation of this issue does not require user interaction.","severity":"medium","score":5.3,"published":"2022-08-20T00:00:30.000Z","modified":"2025-02-12T18:57:06.411Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"magento/community-edition","ranges":[{"events":[{"introduced":"2.4.3-p1"},{"fixed":"2.4.3-p3"}],"type":"ECOSYSTEM"}],"versions":["2.4.3-p1","2.4.3-p2"],"fixed":["2.4.3-p3"]},{"ecosystem":"Packagist","name":"magento/community-edition","ranges":[{"events":[{"introduced":"2.3.7-p1"},{"fixed":"2.3.7-p4"}],"type":"ECOSYSTEM"}],"versions":["2.3.7-p1","2.3.7-p2","2.3.7-p3"],"fixed":["2.3.7-p4"]},{"ecosystem":"Packagist","name":"magento/project-community-edition","ranges":[{"events":[{"introduced":"0"},{"last_affected":"2.0.2"}],"type":"ECOSYSTEM"}],"versions":["0.1.0-alpha100","0.1.0-alpha101","0.1.0-alpha102","0.1.0-alpha103","0.1.0-alpha104","0.1.0-alpha105","0.1.0-alpha106","0.1.0-alpha107","0.1.0-alpha108","0.1.0-alpha89","0.1.0-alpha90","0.1.0-alpha91","0.1.0-alpha92","0.1.0-alpha93","0.1.0-alpha94","0.1.0-alpha95","0.1.0-alpha96","0.1.0-alpha97","0.1.0-alpha98","0.1.0-alpha99","0.42.0-beta1","0.42.0-beta10","0.42.0-beta11","0.42.0-beta2","0.42.0-beta3","0.42.0-beta4","0.42.0-beta5","0.42.0-beta6","0.42.0-beta7","0.42.0-beta8","0.42.0-beta9","0.74.0-beta1","0.74.0-beta10","0.74.0-beta11","0.74.0-beta12","0.74.0-beta13","0.74.0-beta14","0.74.0-beta15","0.74.0-beta16","0.74.0-beta2","0.74.0-beta3","0.74.0-beta4","0.74.0-beta5","0.74.0-beta6","0.74.0-beta7","0.74.0-beta8","0.74.0-beta9","1.0.0-beta","2.0.0","2.0.0-rc","2.0.0-rc2","2.0.1","2.0.2"],"fixed":[]},{"ecosystem":"Packagist","name":"magento/community-edition","ranges":[],"versions":["2.3.7"],"fixed":[]},{"ecosystem":"Packagist","name":"magento/community-edition","ranges":[],"versions":["2.4.4"],"fixed":[]},{"ecosystem":"Packagist","name":"magento/community-edition","ranges":[],"versions":["2.4.3"],"fixed":[]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2022-35692","https://helpx.adobe.com/security/products/magento/apsb22-38.html"],"sources":[{"name":"OSV","id":"GHSA-gm4m-9rm8-7rxj","modified":"2025-02-12T18:57:06.411286Z","url":"https://osv.dev/vulnerability/GHSA-gm4m-9rm8-7rxj"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","score":5.3}]}