{"id":"GHSA-gjvc-55fw-v6vq","aliases":["CVE-2023-4455"],"title":"Wallabag user can delete own API client unintentionally","titleSource":"OSV","descriptionSource":"OSV","declaredSeverity":"MODERATE","description":"# Description\nwallabag was discovered to contain a Cross-Site Request Forgery (CSRF) which allows attackers to arbitrarily delete API key via `/developer/client/delete/{id}` \n\nThis vulnerability has a CVSSv3.1 score of 6.5.\n\n**You should immediately patch your instance to version 2.6.3 or higher if you have more than one user and/or having open registration**.\n\n# Resolution\n\nThis action is now doable only via POST method, which ensures that we can't do it via a 3rd-party website. \n\n# Credits \n\nWe would like to thank @tht1997 for reporting this issue through huntr.dev.\n\nReference: https://huntr.dev/bounties/5ab1b206-5fe8-4737-b275-d705e76f193a/","severity":"medium","score":6.5,"published":"2023-08-21T20:28:03.000Z","modified":"2024-02-16T08:05:24.353Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"wallabag/wallabag","sources":[{"name":"OSV · GHSA-gjvc-55fw-v6vq","url":"https://osv.dev/vulnerability/GHSA-gjvc-55fw-v6vq"}],"ranges":[{"events":[{"introduced":"2.0.0-alpha.1"},{"fixed":"2.6.3"}],"type":"ECOSYSTEM"}],"versions":["2.0.0","2.0.0-alpha.1","2.0.0-alpha.2","2.0.0-beta.1","2.0.0-beta.2","2.0.1","2.0.2","2.0.3","2.0.4","2.0.5","2.0.6","2.0.7","2.0.8","2.1.0","2.1.1","2.1.2","2.1.3","2.1.4","2.1.5","2.1.6","2.1.6.1","2.2.0","2.2.1","2.2.2","2.2.3","2.3.0","2.3.1","2.3.2","2.3.3","2.3.4","2.3.5","2.3.6","2.3.7","2.3.8","2.4.0","2.4.1","2.4.2","2.4.3","2.5.0","2.5.1","2.5.2","2.5.3","2.5.4","2.6.0","2.6.1","2.6.2"],"fixed":["2.6.3"]}],"sourceAffected":[],"references":["https://github.com/wallabag/wallabag/security/advisories/GHSA-gjvc-55fw-v6vq","https://github.com/wallabag/wallabag/commit/ffcc5c9062fcc8cd922d7d6d65edbe5efae96806","https://github.com/wallabag/wallabag","https://huntr.dev/bounties/5ab1b206-5fe8-4737-b275-d705e76f193a"],"sources":[{"name":"OSV","id":"GHSA-gjvc-55fw-v6vq","modified":"2024-02-16T08:05:24.353339Z","url":"https://osv.dev/vulnerability/GHSA-gjvc-55fw-v6vq"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","score":6.5}],"products":[],"remediation":[],"kev":{"status":"not-listed","checkedAt":"2026-10-28T20:25:31.474Z"},"coverage":[{"source":"NVD","status":"not-checked"},{"source":"GHSA","status":"not-checked"},{"source":"EUVD","status":"not-checked"},{"source":"EPSS","status":"not-checked"}],"evidence":[]}