{"id":"GHSA-ghw3-5qvm-3mqc","aliases":["BIT-codeigniter-2022-23556","CVE-2022-23556"],"title":"CodeIgniter4 allows spoofing of IP address when using proxy","description":"### Impact\nThis vulnerability may allow attackers to spoof their IP address when your server is behind a reverse proxy.\n\n### Patches\nUpgrade to v4.2.11 or later, and configure `Config\\App::$proxyIPs`.\n\n### Workarounds\nDo not use `$request->getIPAddress()`.\n\n### References\n- https://codeigniter4.github.io/userguide/incoming/request.html#CodeIgniter\\HTTP\\Request::getIPAddress\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in [codeigniter4/CodeIgniter4](https://github.com/codeigniter4/CodeIgniter4/issues)\n* Email us at [SECURITY.md](https://github.com/codeigniter4/CodeIgniter4/blob/develop/SECURITY.md)\n","severity":"high","score":7,"published":"2022-12-22T19:59:58.000Z","modified":"2023-12-06T01:01:59.440Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"codeigniter4/framework","ranges":[{"events":[{"introduced":"0"},{"fixed":"4.2.11"}],"type":"ECOSYSTEM"}],"versions":["4.0.0","4.0.0-rc.4","v4.0.0-alpha.3","v4.0.0-alpha.4","v4.0.0-alpha.5","v4.0.0-beta.1","v4.0.0-beta.2","v4.0.0-beta.3","v4.0.0-beta.4","v4.0.0-rc.1","v4.0.0-rc.2","v4.0.0-rc.2.1","v4.0.0-rc.3","v4.0.1","v4.0.2","v4.0.3","v4.0.4","v4.0.5","v4.1.0","v4.1.1","v4.1.2","v4.1.3","v4.1.4","v4.1.5","v4.1.6","v4.1.7","v4.1.8","v4.1.9","v4.2.0","v4.2.1","v4.2.10","v4.2.2","v4.2.3","v4.2.4","v4.2.5","v4.2.6","v4.2.7","v4.2.8","v4.2.9"],"fixed":["4.2.11"]}],"references":["https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-ghw3-5qvm-3mqc","https://nvd.nist.gov/vuln/detail/CVE-2022-23556","https://github.com/codeigniter4/CodeIgniter4/commit/5ca8c99b2db09a2a08a013836628028ddc984659","https://codeigniter4.github.io/userguide/incoming/request.html#CodeIgniter\\HTTP\\Request::getIPAddress","https://github.com/FriendsOfPHP/security-advisories/blob/master/codeigniter4/framework/CVE-2022-23556.yaml","https://github.com/codeigniter4/CodeIgniter4"],"sources":[{"name":"OSV","id":"GHSA-ghw3-5qvm-3mqc","modified":"2023-12-06T01:01:59.440156Z","url":"https://osv.dev/vulnerability/GHSA-ghw3-5qvm-3mqc"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:L","score":7}],"evidence":[]}