{"id":"GHSA-frv8-xjcp-hrm2","aliases":["CVE-2010-2958"],"title":"phpMyAdmin Cross-site Scripting vulnerability","description":"Cross-site scripting (XSS) vulnerability in libraries/Error.class.php in phpMyAdmin 3.x before 3.3.6 allows remote attackers to inject arbitrary web script or HTML via vectors related to a PHP backtrace and error messages (aka debugging messages), a different vulnerability than CVE-2010-3056.","severity":"medium","score":5.3,"published":"2022-05-17T05:48:25.000Z","modified":"2025-04-12T02:57:06.608Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"3.0.0"},{"fixed":"3.3.6"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["3.3.6"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2010-2958","https://github.com/phpmyadmin/composer","http://phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin%3Ba=commit%3Bh=133a77fac7d31a38703db2099a90c1b49de62e37","http://phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin;a=commit;h=133a77fac7d31a38703db2099a90c1b49de62e37","http://www.openwall.com/lists/oss-security/2010/09/01/2","http://www.openwall.com/lists/oss-security/2010/09/01/3","http://www.phpmyadmin.net/home_page/security/PMASA-2010-6.php"],"sources":[{"name":"OSV","id":"GHSA-frv8-xjcp-hrm2","modified":"2025-04-12T02:57:06.608620Z","url":"https://osv.dev/vulnerability/GHSA-frv8-xjcp-hrm2"}],"assessments":[{"source":"OSV","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","score":5.3}]}