{"id":"GHSA-f884-gm86-cg3q","aliases":[],"title":"PrestaShop module ps_facetedsearch might be vulnerable from CVE-2017-9841","description":"### Impact\n\nWe have identified that some ps_facetedsearch module ZIP archives have been built with phpunit dev dependencies. PHPUnit contains a php script that would allow, on a webserver, an attacker to perform a RCE.\n\nThis vulnerability impacts\n- phpunit before 4.8.28 and 5.x before 5.6.3 as reported in [CVE-2017-9841](https://nvd.nist.gov/vuln/detail/CVE-2017-9841)\n- phpunit >= 5.63 before 7.5.19 and 8.5.1 (this is a newly found vulnerability that is currently being submitted as a CVE after disclosure was provided to phpunit maintainers)\n\n### Patches\n\nIn the [security patch](https://github.com/PrestaShop/ps_facetedsearch/releases/tag/v3.4.1), we look for the unwanted vendor/phpunit folder and remove it if we find it. This allows users to fix the security issue when upgrading.\n\n### Workarounds\nUsers can also simply remove the unwanted vendor/phpunit folder.\n\n### References\nhttps://nvd.nist.gov/vuln/detail/CVE-2017-9841\n\n### For more information\nIf you have any questions or comments about this advisory, email us at security@prestashop.com","severity":"high","score":null,"published":"2020-01-07T17:20:47.000Z","modified":"2024-12-02T05:46:15.962Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"prestashop/ps_facetedsearch","ranges":[{"events":[{"introduced":"0"},{"fixed":"3.4.1"}],"type":"ECOSYSTEM"}],"versions":["v1.0.1","v1.0.2","v2.1.0","v2.1.1","v2.1.2","v2.2.0","v2.2.1","v3.0.0","v3.0.1","v3.0.2","v3.0.3","v3.0.4","v3.0.5","v3.0.6","v3.0.7","v3.1.0","v3.2.0","v3.2.1","v3.3.0","v3.4.0"],"fixed":["3.4.1"]}],"references":["https://github.com/PrestaShop/ps_facetedsearch/security/advisories/GHSA-f884-gm86-cg3q","https://github.com/PrestaShop/ps_facetedsearch/commit/47c4785a21ee3b1734b2d46f044f9659a151feca"],"sources":[{"name":"OSV","id":"GHSA-f884-gm86-cg3q","modified":"2024-12-02T05:46:15.962124Z","url":"https://osv.dev/vulnerability/GHSA-f884-gm86-cg3q"}],"assessments":[]}