{"id":"GHSA-9mh6-g99m-ppcw","aliases":["CVE-2025-58769"],"title":"auth0-PHP SDK Does Not Properly Handle File Types in Bulk User Import","titleSource":"OSV","descriptionSource":"OSV","declaredSeverity":"LOW","description":"### Overview\nIn applications built with the Auth0-PHP SDK, the Bulk User Import endpoint does not validate the file path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs.\n\n### Am I affected?\nYou are affected by this vulnerability if you meet the following preconditions:\n1. Applications using the Auth0-PHP SDK, versions between v3.3.0 and v8.16.0, or\n2. Applications using the following SDKs that rely on the Auth0-PHP SDK versions between v3.3.0 and v8.16.0:\na. Auth0/symfony,\nb. Auth0/laravel-auth0,\nc. Auth0/wordpress.\n\n### Fix\nUpgrade Auth0/Auth0-PHP to version 8.17.0 or greater.\n\n### Acknowledgement\nOkta would like to thank Mohamed Amine Saidani (pwni) for discovering this vulnerability.","severity":"low","score":3.3,"published":"2025-10-01T21:20:45.000Z","modified":"2026-02-04T04:02:19.270Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"auth0/auth0-php","sources":[{"name":"OSV · GHSA-9mh6-g99m-ppcw","url":"https://osv.dev/vulnerability/GHSA-9mh6-g99m-ppcw"}],"ranges":[{"events":[{"introduced":"3.3.0"},{"fixed":"8.17.0"}],"type":"ECOSYSTEM"}],"versions":["3.3.0","3.3.1","3.3.2","3.3.3","3.3.4","3.3.5","3.3.6","3.3.7","3.4.0","3.4.1","3.4.2","3.4.3","4.0.0","4.0.1","4.0.10","4.0.11","4.0.12","4.0.13","4.0.2","4.0.3","4.0.4","4.0.5","4.0.6","4.0.7","4.0.8","4.0.9","5.0.0","5.0.1","5.0.2","5.0.3","5.0.4","5.0.5","5.0.6","5.1.0","5.1.1","5.2.0","5.3.0","5.3.1","5.3.2","5.4.0","5.5.0","5.5.1","5.6.0","5.7.0","6.0.0-alpha.1","6.0.0-alpha.2","7.0.0","7.1.0","7.2.0","7.3.0","7.4.0","7.5.0","7.6.0","7.6.1","7.6.2","7.7.0","7.8.0","7.9.0","7.9.1","7.9.2","8.0.0","8.0.0-BETA1","8.0.0-BETA2","8.0.0-BETA3","8.0.1","8.0.2","8.0.3","8.0.4","8.0.5","8.0.6","8.1.0","8.10.0","8.11.0","8.11.1","8.12.0","8.13.0","8.14.0","8.15.0","8.16.0","8.2.0","8.2.1","8.3.0","8.3.1","8.3.2","8.3.3","8.3.4","8.3.5","8.3.6","8.3.7","8.3.8","8.4.0","8.5.0","8.6.0","8.7.0","8.7.1","8.8.0","8.9.0","8.9.1","8.9.3"],"fixed":["8.17.0"]}],"sourceAffected":[],"references":["https://github.com/auth0/auth0-PHP/security/advisories/GHSA-9mh6-g99m-ppcw","https://github.com/auth0/laravel-auth0/security/advisories/GHSA-hjfh-5jmm-xr24","https://github.com/auth0/symfony/security/advisories/GHSA-7jp2-5h22-m432","https://github.com/auth0/wordpress/security/advisories/GHSA-w22c-pw5m-482x","https://nvd.nist.gov/vuln/detail/CVE-2025-58769","https://github.com/auth0/auth0-PHP/commit/9026da58f5c381cd4cb5932de829eff6eacbb65c","https://github.com/auth0/auth0-PHP","https://github.com/auth0/auth0-PHP/releases/tag/8.17.0"],"sources":[{"name":"OSV","id":"GHSA-9mh6-g99m-ppcw","modified":"2026-02-04T04:02:19.270003Z","url":"https://osv.dev/vulnerability/GHSA-9mh6-g99m-ppcw"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N","score":3.3}],"products":[],"remediation":[],"kev":{"status":"not-listed","checkedAt":"2026-10-28T18:15:34.797Z"},"coverage":[{"source":"NVD","status":"not-checked"},{"source":"GHSA","status":"not-checked"},{"source":"EUVD","status":"not-checked"},{"source":"EPSS","status":"not-checked"}],"evidence":[]}