{"id":"GHSA-86pc-6mm8-542r","aliases":["CVE-2019-8148"],"title":"Magento 2 Community Edition XSS Vulnerability","description":"A stored cross-site scripting (XSS) vulnerability exists in Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated admin user can inject arbitrary JavaScript code when creating a content page via page builder.\n\nAs per [the Magento Release 2.3.3](https://web.archive.org/web/20201126132230/https://devdocs.magento.com/guides/v2.3/release-notes/release-notes-2-3-3-commerce.html#new-security-only-patch-available), if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.\n","severity":"medium","score":4.8,"published":"2022-05-24T17:00:28.000Z","modified":"2024-02-16T08:02:47.570Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"magento/community-edition","ranges":[{"events":[{"introduced":"2.3.0"},{"fixed":"2.3.2-p2"}],"type":"ECOSYSTEM"}],"versions":["2.3.0","2.3.1","2.3.2"],"fixed":["2.3.2-p2"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2019-8148","https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8148.yaml","https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update","https://web.archive.org/web/20220121051105/https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update"],"sources":[{"name":"OSV","id":"GHSA-86pc-6mm8-542r","modified":"2024-02-16T08:02:47.570157Z","url":"https://osv.dev/vulnerability/GHSA-86pc-6mm8-542r"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","score":4.8}]}