{"id":"GHSA-7rf8-9r8f-qf59","aliases":["CVE-2016-2559"],"title":"phpMyAdmin Cross-site scripting (XSS) vulnerability in SQL parser","titleSource":"OSV","descriptionSource":"OSV","declaredSeverity":"MODERATE","description":"Cross-site scripting (XSS) vulnerability in the format function in libraries/sql-parser/src/Utils/Error.php in the SQL parser in phpMyAdmin 4.5.x before 4.5.5.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted query.","severity":"medium","score":5.4,"published":"2022-05-17T03:31:15.000Z","modified":"2024-04-24T17:43:37.988Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","sources":[{"name":"OSV · GHSA-7rf8-9r8f-qf59","url":"https://osv.dev/vulnerability/GHSA-7rf8-9r8f-qf59"}],"ranges":[{"events":[{"introduced":"4.5"},{"fixed":"4.5.5.1"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["4.5.5.1"]}],"sourceAffected":[],"references":["https://nvd.nist.gov/vuln/detail/CVE-2016-2559","https://github.com/phpmyadmin/phpmyadmin/commit/3a6a9a807d99371ee126635e1a505fc1fe0df32c","https://github.com/phpmyadmin/composer","https://www.phpmyadmin.net/security/PMASA-2016-10","http://lists.fedoraproject.org/pipermail/package-announce/2016-March/178562.html","http://lists.fedoraproject.org/pipermail/package-announce/2016-March/178869.html"],"sources":[{"name":"OSV","id":"GHSA-7rf8-9r8f-qf59","modified":"2024-04-24T17:43:37.988838Z","url":"https://osv.dev/vulnerability/GHSA-7rf8-9r8f-qf59"}],"assessments":[{"source":"OSV","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4}],"products":[],"remediation":[],"kev":{"status":"not-listed","checkedAt":"2026-10-29T02:25:31.980Z"},"coverage":[{"source":"NVD","status":"not-checked"},{"source":"GHSA","status":"not-checked"},{"source":"EUVD","status":"not-checked"},{"source":"EPSS","status":"not-checked"}],"evidence":[]}