{"id":"GHSA-6hr3-44gx-g6wh","aliases":["BIT-phpmyadmin-2023-25727","CVE-2023-25727"],"title":"Cross-site Scripting vulnerability in drag-and-drop upload of phpMyAdmin","titleSource":"OSV","descriptionSource":"OSV","declaredSeverity":"MODERATE","description":"In phpMyAdmin before 4.9.11 and 5.x before 5.2.1, an authenticated user can trigger Cross-site Scripting (XSS) by uploading a crafted .sql file through the drag-and-drop interface. By disabling the configuration directive `$cfg['enable_drag_drop_import']`, users will be unable to use the drag and drop upload which would protect against the vulnerability.","severity":"medium","score":5.4,"published":"2023-02-13T06:30:59.000Z","modified":"2025-03-21T15:52:59.263Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","sources":[{"name":"OSV · GHSA-6hr3-44gx-g6wh","url":"https://osv.dev/vulnerability/GHSA-6hr3-44gx-g6wh"}],"ranges":[{"events":[{"introduced":"4.3.0"},{"fixed":"4.9.11"}],"type":"ECOSYSTEM"}],"versions":["4.7.0","4.7.1","4.7.2","4.7.3","4.7.4","4.7.5","4.7.6","4.7.7","4.7.8","4.7.9","4.8.0","4.8.0.1","4.8.1","4.8.2","4.8.3","4.8.4","4.8.5","4.9.0","4.9.0.1","4.9.1","4.9.10","4.9.2","4.9.3","4.9.4","4.9.5","4.9.6","4.9.7","4.9.8","4.9.9"],"fixed":["4.9.11"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","sources":[{"name":"OSV · GHSA-6hr3-44gx-g6wh","url":"https://osv.dev/vulnerability/GHSA-6hr3-44gx-g6wh"}],"ranges":[{"events":[{"introduced":"5.0"},{"fixed":"5.2.1"}],"type":"ECOSYSTEM"}],"versions":["5.0.0","5.0.0.1","5.0.1","5.0.2","5.0.3","5.0.4","5.1.0","5.1.1","5.1.2","5.1.3","5.1.4","5.2.0"],"fixed":["5.2.1"]}],"sourceAffected":[],"references":["https://nvd.nist.gov/vuln/detail/CVE-2023-25727","https://github.com/phpmyadmin/phpmyadmin/commit/53f70fd7f3b388639922e6cc1ca51fbe890c91cc","https://github.com/phpmyadmin/phpmyadmin/commit/efa2406695551667f726497750d3db91fb6f662e","https://github.com/phpmyadmin/composer","https://www.phpmyadmin.net/security/PMASA-2023-1"],"sources":[{"name":"OSV","id":"GHSA-6hr3-44gx-g6wh","modified":"2025-03-21T15:52:59.263497Z","url":"https://osv.dev/vulnerability/GHSA-6hr3-44gx-g6wh"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4}],"products":[],"remediation":[],"kev":{"status":"not-listed","checkedAt":"2026-10-28T18:20:33.032Z"},"coverage":[{"source":"NVD","status":"not-checked"},{"source":"GHSA","status":"not-checked"},{"source":"EUVD","status":"not-checked"},{"source":"EPSS","status":"not-checked"}],"evidence":[]}