{"id":"GHSA-6cq5-8cj7-g558","aliases":["BIT-codeigniter-2022-46170","CVE-2022-46170"],"title":"CodeIgniter4 Potential Session Handlers Vulnerability","description":"### Impact\nWhen an application uses (1) multiple session cookies (e.g., one for user pages and one for admin pages) and (2)  a session handler is set to `DatabaseHandler`, `MemcachedHandler`, or `RedisHandler`, then if an attacker gets one session cookie (e.g., one for user pages), they may be able to access pages that require another session cookie (e.g., for admin pages).\n\n### Patches\nUpgrade to version 4.2.11 or later.\n\n### Workarounds\n- Use only one session cookie.\n\n### References\n- https://codeigniter4.github.io/userguide/libraries/sessions.html#session-drivers\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in [codeigniter4/CodeIgniter4](https://github.com/codeigniter4/CodeIgniter4/issues)\n* Email us at [SECURITY.md](https://github.com/codeigniter4/CodeIgniter4/blob/develop/SECURITY.md)\n","severity":"high","score":8.6,"published":"2022-12-22T20:01:18.000Z","modified":"2023-12-06T01:02:43.191Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"codeigniter4/framework","ranges":[{"events":[{"introduced":"0"},{"fixed":"4.2.11"}],"type":"ECOSYSTEM"}],"versions":["4.0.0","4.0.0-rc.4","v4.0.0-alpha.3","v4.0.0-alpha.4","v4.0.0-alpha.5","v4.0.0-beta.1","v4.0.0-beta.2","v4.0.0-beta.3","v4.0.0-beta.4","v4.0.0-rc.1","v4.0.0-rc.2","v4.0.0-rc.2.1","v4.0.0-rc.3","v4.0.1","v4.0.2","v4.0.3","v4.0.4","v4.0.5","v4.1.0","v4.1.1","v4.1.2","v4.1.3","v4.1.4","v4.1.5","v4.1.6","v4.1.7","v4.1.8","v4.1.9","v4.2.0","v4.2.1","v4.2.10","v4.2.2","v4.2.3","v4.2.4","v4.2.5","v4.2.6","v4.2.7","v4.2.8","v4.2.9"],"fixed":["4.2.11"]}],"references":["https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-6cq5-8cj7-g558","https://nvd.nist.gov/vuln/detail/CVE-2022-46170","https://github.com/codeigniter4/CodeIgniter4/commit/f9fb6574fbeb5a4aa63f7ea87296523e10db9328","https://codeigniter4.github.io/userguide/libraries/sessions.html#session-drivers","https://github.com/FriendsOfPHP/security-advisories/blob/master/codeigniter4/framework/CVE-2022-46170.yaml","https://github.com/codeigniter4/CodeIgniter4"],"sources":[{"name":"OSV","id":"GHSA-6cq5-8cj7-g558","modified":"2023-12-06T01:02:43.191201Z","url":"https://osv.dev/vulnerability/GHSA-6cq5-8cj7-g558"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L","score":8.6}]}