{"id":"GHSA-5p73-qg2v-383h","aliases":["CVE-2022-31158"],"title":"LTI 1.3 Tool Library's Nonce Claim Value not validated against nonce value sent in Authentication Request before v5.0","description":"### Impact\n\nNonce Claim Value was not being validated against the nonce value sent in the Authentication Request.\n\n### Patches\n\nUsers should upgrade to version 5.0 immediately\n\n### Workarounds\n\nNone.\n\n","severity":"high","score":7.5,"published":"2022-07-15T20:55:50.000Z","modified":"2023-11-08T04:09:28.099Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"packbackbooks/lti-1-3-php-library","ranges":[{"events":[{"introduced":"0"},{"fixed":"5.0"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["5.0"]}],"references":["https://github.com/packbackbooks/lti-1-3-php-library/security/advisories/GHSA-5p73-qg2v-383h","https://nvd.nist.gov/vuln/detail/CVE-2022-31158","https://github.com/packbackbooks/lti-1-3-php-library","https://openid.net/specs/openid-connect-core-1_0.html#AuthRequest"],"sources":[{"name":"OSV","id":"GHSA-5p73-qg2v-383h","modified":"2023-11-08T04:09:28.099168Z","url":"https://osv.dev/vulnerability/GHSA-5p73-qg2v-383h"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","score":7.5}]}