{"id":"GHSA-4h9c-v5vg-5m6m","aliases":["CVE-2021-21408"],"title":"Access to restricted PHP code by dynamic static class access in smarty","description":"### Impact\nTemplate authors could run restricted static php methods.\n\n### Patches\nPlease upgrade to 3.1.40 or higher.\n\n### References\nSee the [documentation on Smarty security features](https://www.smarty.net/docs/en/advanced.features.tpl#advanced.features.security) on the static_classes access filter.\n\n### For more information\nIf you have any questions or comments about this advisory please open an issue in [the Smarty repo](https://github.com/smarty-php/smarty)\n","severity":"high","score":8.8,"published":"2022-01-12T22:43:42.000Z","modified":"2026-07-08T06:28:50.962Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"smarty/smarty","ranges":[{"events":[{"introduced":"0"},{"fixed":"3.1.43"}],"type":"ECOSYSTEM"}],"versions":["v2.6.24","v2.6.25","v2.6.26","v2.6.27","v2.6.28","v2.6.29","v2.6.30","v2.6.31","v2.6.33","v3.1.11","v3.1.12","v3.1.13","v3.1.14","v3.1.15","v3.1.16","v3.1.17","v3.1.18","v3.1.19","v3.1.20","v3.1.21","v3.1.23","v3.1.24","v3.1.25","v3.1.26","v3.1.27","v3.1.28","v3.1.29","v3.1.30","v3.1.31","v3.1.32","v3.1.33","v3.1.34","v3.1.35","v3.1.36","v3.1.37","v3.1.37.1","v3.1.38","v3.1.39","v3.1.40","v3.1.41","v3.1.42"],"fixed":["3.1.43"]},{"ecosystem":"Packagist","name":"smarty/smarty","ranges":[{"events":[{"introduced":"4.0.0"},{"fixed":"4.0.3"}],"type":"ECOSYSTEM"}],"versions":["v4.0.0","v4.0.1","v4.0.2"],"fixed":["4.0.3"]}],"references":["https://github.com/smarty-php/smarty/security/advisories/GHSA-4h9c-v5vg-5m6m","https://nvd.nist.gov/vuln/detail/CVE-2021-21408","https://github.com/smarty-php/smarty/commit/19ae410bf56007a5ef24441cdc6414619cfaf664","https://github.com/FriendsOfPHP/security-advisories/blob/master/smarty/smarty/CVE-2021-21408.yaml","https://github.com/smarty-php/smarty","https://github.com/smarty-php/smarty/releases/tag/v3.1.43","https://github.com/smarty-php/smarty/releases/tag/v4.0.3","https://lists.debian.org/debian-lts-announce/2022/05/msg00005.html","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/BRAJVDRGCIY5UZ2PQHKDTT7RMKG6WJQQ","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/L777JIBIWJV34HS7LXPIDWASG7TT4LNI","https://security.gentoo.org/glsa/202209-09","https://www.debian.org/security/2022/dsa-5151"],"sources":[{"name":"OSV","id":"GHSA-4h9c-v5vg-5m6m","modified":"2026-07-08T06:28:50.962307199Z","url":"https://osv.dev/vulnerability/GHSA-4h9c-v5vg-5m6m"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8}]}