{"id":"GHSA-4gmg-gwjh-3mmr","aliases":["CVE-2016-1927"],"title":"phpMyAdmin Cryptographic Vulnerability","description":"The `suggestPassword` function in `js/functions.js` in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 relies on the `Math.random` JavaScript function, which makes it easier for remote attackers to guess passwords via a brute-force approach.","severity":"high","score":7.5,"published":"2022-05-17T03:43:03.000Z","modified":"2024-12-07T05:47:39.926Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.0.0"},{"fixed":"4.0.10.13"}],"type":"ECOSYSTEM"}],"versions":["4.0.0","4.0.1","4.0.10","4.0.10.1","4.0.10.2","4.0.10.3","4.0.10.4","4.0.10.5","4.0.10.6","4.0.10.7","4.0.10.8","4.0.10.9","4.0.2","4.0.3","4.0.4","4.0.4.1","4.0.4.2","4.0.5","4.0.6","4.0.7","4.0.8","4.0.9"],"fixed":["4.0.10.13"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.4.0"},{"fixed":"4.4.15.3"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["4.4.15.3"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.5.0"},{"fixed":"4.5.4"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["4.5.4"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2016-1927","https://github.com/phpmyadmin/phpmyadmin/commit/2369daa7f5f550797f560e6b46a021e4558c2d72","https://github.com/phpmyadmin/phpmyadmin/commit/5530a72e162fab442218486a90ff3365c96fde98","https://github.com/phpmyadmin/phpmyadmin/commit/6a96e67487f2faecb4de4204fee9b96b94020720","https://github.com/phpmyadmin/phpmyadmin/commit/8b6737735be5787d0b98c6cdfe2c7e3131b1bc95","https://github.com/phpmyadmin/phpmyadmin/commit/8dedcc1a175eb07debd4fe116407c43694c60b22","https://github.com/phpmyadmin/phpmyadmin/commit/912856b432d794201884c36e5f390d446339b6e4","https://github.com/phpmyadmin/phpmyadmin","http://lists.fedoraproject.org/pipermail/package-announce/2016-February/176483.html","http://lists.fedoraproject.org/pipermail/package-announce/2016-February/176739.html","http://lists.opensuse.org/opensuse-updates/2016-02/msg00028.html","http://lists.opensuse.org/opensuse-updates/2016-02/msg00049.html","http://www.debian.org/security/2016/dsa-3627","http://www.phpmyadmin.net/home_page/security/PMASA-2016-4.php"],"sources":[{"name":"OSV","id":"GHSA-4gmg-gwjh-3mmr","modified":"2024-12-07T05:47:39.926215Z","url":"https://osv.dev/vulnerability/GHSA-4gmg-gwjh-3mmr"}],"assessments":[{"source":"OSV","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5}]}