{"id":"GHSA-3q5x-7mxp-rp6j","aliases":["CVE-2019-8135"],"title":"Remote code execution via vulnerable Symphony dependecy injection","description":"A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. Dependency injection through Symphony framework allows service identifiers to be derived from user controlled data, which can lead to remote code execution.\nAs per [the Magento Release 2.3.3](https://web.archive.org/web/20201126132230/https://devdocs.magento.com/guides/v2.3/release-notes/release-notes-2-3-3-commerce.html#new-security-only-patch-available), if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.\n","severity":"critical","score":9.8,"published":"2019-11-12T22:59:32.000Z","modified":"2024-02-16T08:03:28.691Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"magento/community-edition","ranges":[{"events":[{"introduced":"2.2"},{"fixed":"2.2.10"}],"type":"ECOSYSTEM"}],"versions":["2.2.0","2.2.1","2.2.2","2.2.3","2.2.4","2.2.5","2.2.6","2.2.7","2.2.8","2.2.9"],"fixed":["2.2.10"]},{"ecosystem":"Packagist","name":"magento/community-edition","ranges":[{"events":[{"introduced":"2.3"},{"fixed":"2.3.2-p2"}],"type":"ECOSYSTEM"}],"versions":["2.3.0","2.3.1","2.3.2"],"fixed":["2.3.2-p2"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2019-8135","https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8135.yaml","https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update"],"sources":[{"name":"OSV","id":"GHSA-3q5x-7mxp-rp6j","modified":"2024-02-16T08:03:28.691308Z","url":"https://osv.dev/vulnerability/GHSA-3q5x-7mxp-rp6j"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8}]}