{"id":"GHSA-3pwp-g2mj-5p3v","aliases":["CVE-2026-45293"],"title":"WordPress Coding Standards (WordPressCS) contains an arbitrary code execution vulnerability","description":"### Impact\n\nWordPress Coding Standards (WordPressCS) versions before 3.4.1 contain an arbitrary code execution vulnerability in the `WordPress.WP.EnqueuedResourceParameters` sniff. As a result, running PHPCS with WordPressCS over untrusted PHP code, for example, in a CI pipeline that lints pull requests, or on a developer machine reviewing third-party code, could lead to arbitrary command execution on the scanning host.\n\nThis affects users of the `WordPress` and `WordPress-Extra` rulesets. The `WordPress-Core` ruleset and the `WordPress-Docs` ruleset are not affected.\n\nThe vulnerability happens when the sniff checks whether the `$var` argument passed to functions such as `wp_enqueue_script()` or `wp_register_script()` evaluates to a falsy value. The sniff's `is_falsy()` method reconstructed the argument and ran it through `eval()`. Because of this, a maliciously crafted `$ver` argument such as `'system'('id')` would be executed during the scan.\n\n### Patches\n\nThis issue has been fixed in WordPressCS 3.4.1. We recommend all users upgrade to 3.4.1 or later.\n\n### Workaround\n\nUsers of the `WordPress` and `WordPress-Extra` rulesets, who cannot upgrade immediately, can disable the affected sniff by adding an `<exclude>` tag to their custom ruleset (the `<rule>` `ref` value might vary depending on the ruleset):\n\n```xml\n<rule ref=\"WordPress\">\n\t<exclude name=\"WordPress.WP.EnqueuedResourceParameters\"/>\n</rule>\n```\n\nTo verify that the sniff has been disabled, run PHPCS with the `-e` flag, which lists all the sniffs a standard will run. `WordPress.WP.EnqueuedResourceParameters` should no longer appear in the output under the `WordPress` section:\n\n```\nphpcs -e --standard=/path/to/ruleset.xml\n```\n\n### Credits\n\nMany thanks to [@FORIMOC](https://github.com/FORIMOC) for responsibly disclosing this vulnerability.\n\n### How can I report a security bug?\n\nPlease report security vulnerabilities privately via [the \"Security and quality\" tab on the WPCS repository](https://github.com/WordPress/WordPress-Coding-Standards/security).","severity":"high","score":8.6,"published":"2026-07-28T14:28:12.000Z","modified":"2026-07-28T14:56:51.873Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"wp-coding-standards/wpcs","ranges":[{"events":[{"introduced":"0.14.1"},{"fixed":"3.4.1"}],"type":"ECOSYSTEM"}],"versions":["0.14.1","1.0.0","1.1.0","1.2.0","1.2.1","2.0.0","2.0.0-RC1","2.1.0","2.1.1","2.2.0","2.2.1","2.3.0","3.0.0","3.0.1","3.1.0","3.2.0","3.3.0","3.4.0"],"fixed":["3.4.1"]}],"references":["https://github.com/WordPress/WordPress-Coding-Standards/security/advisories/GHSA-3pwp-g2mj-5p3v","https://github.com/WordPress/WordPress-Coding-Standards/pull/2771","https://github.com/WordPress/WordPress-Coding-Standards/commit/a29048d0bbef5cf25d42349c74e4072d3cbc8325","https://github.com/WordPress/WordPress-Coding-Standards","https://github.com/WordPress/WordPress-Coding-Standards/releases/tag/3.4.1"],"sources":[{"name":"OSV","id":"GHSA-3pwp-g2mj-5p3v","modified":"2026-07-28T14:56:51.873225Z","url":"https://osv.dev/vulnerability/GHSA-3pwp-g2mj-5p3v"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","score":8.6}]}