{"id":"GHSA-2p89-5f22-8qvf","aliases":["CVE-2021-32711","GHSA-f2vv-h5x4-57gr"],"title":"Exposure of Sensitive Information to an Unauthorized Actor","description":"Shopware is an open source eCommerce platform. Versions prior to 6.3.5.1 may leak of information via Store-API. The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. We recommend to update to the current version 6.3.5.1. You can get the update to 6.3.5.1 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 The vulnerability could only be fixed by changing the API system, which involves a non-backward-compatible change. Only consumers of the Store-API should be affected by this change. Please check your plugins if you have it in use. Detailed technical information can be found in the upgrade information. https://github.com/shopware/platform/blob/v6.3.5.1/UPGRADE-6.3.md#6351 ### Workarounds For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659 ### For more information https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021","severity":"critical","score":9.1,"published":"2021-02-10T02:32:21.000Z","modified":"2026-09-10T03:49:15.804Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"shopware/platform","ranges":[{"events":[{"introduced":"0"},{"fixed":"6.3.5.1"}],"type":"ECOSYSTEM"}],"versions":["6.3.0.0","6.3.0.1","6.3.0.2","6.3.1.0","6.3.1.1","6.3.2.0","6.3.2.1","6.3.3.0","6.3.3.1","6.3.4.0","6.3.4.1","6.3.5.0","v6.0.0+ea2","v6.1.0","v6.1.0-rc1","v6.1.0-rc2","v6.1.0-rc3","v6.1.0-rc4","v6.1.1","v6.1.2","v6.1.3","v6.1.4","v6.1.5","v6.1.6","v6.2.0","v6.2.0-RC1","v6.2.1","v6.2.2","v6.2.3"],"fixed":["6.3.5.1"]}],"references":["https://github.com/shopware/platform/security/advisories/GHSA-f2vv-h5x4-57gr","https://nvd.nist.gov/vuln/detail/CVE-2021-32711","https://github.com/shopware/platform/commit/157fb84a8b3b4ace4be165a033d559826704829b","https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2021","https://github.com/shopware/platform","https://github.com/shopware/platform/blob/v6.3.5.1/UPGRADE-6.3.md#6351","https://packagist.org/packages/shopware/platform"],"sources":[{"name":"OSV","id":"GHSA-2p89-5f22-8qvf","modified":"2026-09-10T03:49:15.804263609Z","url":"https://osv.dev/vulnerability/GHSA-2p89-5f22-8qvf"},{"name":"OSV","id":"GHSA-f2vv-h5x4-57gr","modified":"2026-09-10T03:49:14.087860575Z","url":"https://osv.dev/vulnerability/GHSA-f2vv-h5x4-57gr"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","score":9.1}]}