{"id":"GHSA-2p7v-jm8m-g3qq","aliases":["CVE-2016-5739"],"title":"phpMyAdmin vulnerable to Cross-Site Request Forgery","titleSource":"OSV","descriptionSource":"OSV","declaredSeverity":"HIGH","description":"The Transformation implementation in phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not use the no-referrer Content Security Policy (CSP) protection mechanism, which makes it easier for remote attackers to conduct CSRF attacks by reading an authentication token in a Referer header, related to libraries/Header.php.","severity":"high","score":7.5,"published":"2022-05-14T02:08:58.000Z","modified":"2025-04-14T22:27:16.048Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","sources":[{"name":"OSV · GHSA-2p7v-jm8m-g3qq","url":"https://osv.dev/vulnerability/GHSA-2p7v-jm8m-g3qq"}],"ranges":[{"events":[{"introduced":"4.0.10.0"},{"fixed":"4.0.10.16"}],"type":"ECOSYSTEM"}],"versions":["4.0.10.1","4.0.10.2","4.0.10.3","4.0.10.4","4.0.10.5","4.0.10.6","4.0.10.7","4.0.10.8","4.0.10.9"],"fixed":["4.0.10.16"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","sources":[{"name":"OSV · GHSA-2p7v-jm8m-g3qq","url":"https://osv.dev/vulnerability/GHSA-2p7v-jm8m-g3qq"}],"ranges":[{"events":[{"introduced":"4.4.15.0"},{"fixed":"4.4.15.7"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["4.4.15.7"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","sources":[{"name":"OSV · GHSA-2p7v-jm8m-g3qq","url":"https://osv.dev/vulnerability/GHSA-2p7v-jm8m-g3qq"}],"ranges":[{"events":[{"introduced":"4.6.0"},{"fixed":"4.6.3"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["4.6.3"]}],"sourceAffected":[],"references":["https://nvd.nist.gov/vuln/detail/CVE-2016-5739","https://github.com/phpmyadmin/phpmyadmin/commit/1e5716cb96d46efc305381ae0da08e73fe340f05","https://github.com/phpmyadmin/phpmyadmin/commit/2f4950828ec241e8cbdcf13090c2582a6fa620cb","https://github.com/phpmyadmin/phpmyadmin","https://security.gentoo.org/glsa/201701-32","https://web.archive.org/web/20200227223419/http://www.securityfocus.com/bid/91389","https://www.phpmyadmin.net/security/PMASA-2016-28","http://lists.opensuse.org/opensuse-updates/2016-06/msg00113.html","http://lists.opensuse.org/opensuse-updates/2016-06/msg00114.html","http://www.debian.org/security/2016/dsa-3627"],"sources":[{"name":"OSV","id":"GHSA-2p7v-jm8m-g3qq","modified":"2025-04-14T22:27:16.048039Z","url":"https://osv.dev/vulnerability/GHSA-2p7v-jm8m-g3qq"}],"assessments":[{"source":"OSV","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5}],"products":[],"remediation":[],"kev":{"status":"not-listed","checkedAt":"2026-10-28T21:15:31.530Z"},"coverage":[{"source":"NVD","status":"not-checked"},{"source":"GHSA","status":"not-checked"},{"source":"EUVD","status":"not-checked"},{"source":"EPSS","status":"not-checked"}],"evidence":[]}