{"id":"GHSA-2crc-5vq6-386r","aliases":["CVE-2019-8111"],"title":"Magento 2 Community Edition RCE Vulnerability","description":"A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can leverage plugin functionality related to email templates to manipulate the interceptor class in a way that allows an attacker to execute arbitrary code.","severity":"high","score":8.8,"published":"2022-05-24T17:00:24.000Z","modified":"2024-12-08T05:25:22.283Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"magento/community-edition","ranges":[{"events":[{"introduced":"2.2.0"},{"fixed":"2.2.10"}],"type":"ECOSYSTEM"}],"versions":["2.2.0","2.2.1","2.2.2","2.2.3","2.2.4","2.2.5","2.2.6","2.2.7","2.2.8","2.2.9"],"fixed":["2.2.10"]},{"ecosystem":"Packagist","name":"magento/community-edition","ranges":[{"events":[{"introduced":"2.3.0"},{"fixed":"2.3.2-p1"}],"type":"ECOSYSTEM"}],"versions":["2.3.0","2.3.1","2.3.2"],"fixed":["2.3.2-p1"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2019-8111","https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8111.yaml","https://github.com/magento/magento2","https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update","https://web.archive.org/web/20220121051105/https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update"],"sources":[{"name":"OSV","id":"GHSA-2crc-5vq6-386r","modified":"2024-12-08T05:25:22.283238Z","url":"https://osv.dev/vulnerability/GHSA-2crc-5vq6-386r"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8}]}