{"id":"GHSA-237r-r8m4-4q88","aliases":["CVE-2025-21617"],"title":"Guzzle OAuth Subscriber has insufficient nonce entropy","description":"### Impact\n\nNonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source (https://github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php#L192). This can leave servers vulnerable to replay attacks when TLS is not used.\n\n### Patches\n\nUpgrade to version 0.8.1 or higher.\n\n### Workarounds\n\nNo.\n\n### References\n\nIssue is similar to https://nvd.nist.gov/vuln/detail/CVE-2025-22376.","severity":"medium","score":6.3,"published":"2025-01-06T19:23:26.000Z","modified":"2026-07-15T22:00:51.159Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"guzzlehttp/oauth-subscriber","ranges":[{"events":[{"introduced":"0"},{"fixed":"0.8.1"}],"type":"ECOSYSTEM"}],"versions":["0.1.0","0.1.1","0.1.2","0.2.0","0.3.0","0.4.0","0.5.0","0.6.0","0.7.0","0.8.0"],"fixed":["0.8.1"]}],"references":["https://github.com/guzzle/oauth-subscriber/security/advisories/GHSA-237r-r8m4-4q88","https://nvd.nist.gov/vuln/detail/CVE-2025-21617","https://github.com/guzzle/oauth-subscriber/commit/92b619b03bd21396e51c62e6bce83467d2ce8f53","https://github.com/FriendsOfPHP/security-advisories/blob/master/guzzlehttp/oauth-subscriber/CVE-2025-21617.yaml","https://github.com/guzzle/oauth-subscriber","https://github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php#L192","https://github.com/guzzle/oauth-subscriber/releases/tag/0.8.1"],"sources":[{"name":"OSV","id":"GHSA-237r-r8m4-4q88","modified":"2026-07-15T22:00:51.159337328Z","url":"https://osv.dev/vulnerability/GHSA-237r-r8m4-4q88"}],"assessments":[{"source":"OSV","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","score":6.3}]}