{"id":"CVE-2026-17402","aliases":[],"cve":{"records":[{"id":"CVE-2026-17402","source":"ibm","state":"PUBLISHED","reasons":[],"replacements":[],"disputed":false,"unsupportedWhenAssigned":false,"reserved":"2026-07-25T04:58:46.766Z","published":"2026-11-07T04:34:26.726Z","modified":"2026-11-07T04:34:26.726Z"}],"publishers":[{"name":"ibm","role":"CNA","organizationId":"9a959283-ebb5-44b6-b705-dcc2bbced522","modified":"2026-11-07T04:34:26.726Z"}],"references":[{"url":"https://www.ibm.com/support/pages/node/7295635","tags":["vendor-advisory","patch"],"source":"ibm"},{"url":"https://www.ibm.com/support/pages/node/7295637","tags":["vendor-advisory","patch"],"source":"ibm"}],"weaknesses":[{"id":"CWE-78","description":"CWE-78 Improper Neutralization of Special Elements used in an OS Command","source":"ibm"}],"applicability":[],"prioritization":[]},"title":"Multiple Vulnerabilities in IBM API Connect","titleSource":"ibm","descriptionSource":"ibm","description":"IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary commands due to OS command injection. User-supplied input is not properly neutralized before it is passed to the operating system, which could allow commands to run on the underlying host.","score":9.9,"severity":"critical","published":"2026-11-07T04:34:26.726Z","modified":"2026-11-07T04:34:26.726Z","withdrawn":false,"knownExploited":false,"affected":[],"products":[{"vendor":"IBM","name":"API Connect","platforms":[],"versions":[{"version":"12.1.0.0","status":"affected","lessThanOrEqual":"12.1.1.2","versionType":"semver"},{"version":"10.0.8.0","status":"affected","lessThanOrEqual":"10.0.8.12","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:api_connect:12.1.0.0:*:*:*:*:*:*:*","cpe:2.3:a:ibm:api_connect:12.1.1.2:*:*:*:*:*:*:*","cpe:2.3:a:ibm:api_connect:10.0.8.0:*:*:*:*:*:*:*","cpe:2.3:a:ibm:api_connect:10.0.8.12:*:*:*:*:*:*:*"],"source":"ibm","url":"https://www.cve.org/CVERecord?id=CVE-2026-17402"}],"remediation":[{"text":"IBM strongly recommends addressing the vulnerability now by upgrading to v12.1.1.3\nFix Central Link:  https://www.ibm.com/support/pages/node/7290205 \n\n\n\nIBM strongly recommends addressing the vulnerability now by upgrading to 10.0.8.13Fix Central Link: https://www.ibm.com/support/fixcentral/swg/selectFixes?parent=ibm%7EWebSphere&product=ibm/WebSphere/IBM+API+Connect&release=10.0.8.12&platform=All&function=all","source":"ibm","url":"https://www.cve.org/CVERecord?id=CVE-2026-17402"}],"references":["https://www.ibm.com/support/pages/node/7295635","https://www.ibm.com/support/pages/node/7295637"],"sources":[{"name":"CVE","id":"CVE-2026-17402","modified":"2026-11-07T04:34:26.726Z","url":"https://www.cve.org/CVERecord?id=CVE-2026-17402"}],"assessments":[{"source":"ibm","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","score":9.9}],"sourceAffected":[],"observedAt":"2026-11-07T04:44:43.893Z","kev":{"status":"not-listed","checkedAt":"2026-11-08T03:05:30.801Z"},"coverage":[{"source":"NVD","status":"available","checkedAt":"2026-11-07T05:25:35.722Z","attemptedAt":"2026-11-07T05:25:35.722Z"},{"source":"GHSA","status":"no-result","checkedAt":"2026-11-07T05:25:35.934Z","attemptedAt":"2026-11-07T05:25:35.934Z"},{"source":"EUVD","status":"available","checkedAt":"2026-11-07T05:25:36.466Z","attemptedAt":"2026-11-07T05:25:36.466Z"},{"source":"EPSS","status":"no-result","checkedAt":"2026-11-07T05:25:36.131Z","attemptedAt":"2026-11-07T05:25:36.131Z"}],"evidence":[{"source":"NVD","id":"CVE-2026-17402","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-17402","modified":"2026-11-07T05:18:56.630","score":9.9,"vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","checkedAt":"2026-11-07T05:25:35.722Z"},{"source":"ENISA EUVD","id":"EUVD-2026-118782","url":"https://euvd.enisa.europa.eu/vulnerability/EUVD-2026-118782","modified":"Nov 7, 2026, 4:34:26 AM","score":9.9,"vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","checkedAt":"2026-11-07T05:25:36.466Z"}],"aiSummary":{"text":"IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 may allow a remote authenticated attacker to execute arbitrary commands due to OS command injection. User-supplied input is not properly neutralized.","model":"@cf/meta/llama-3.3-70b-instruct-fp8-fast","generatedAt":"2026-11-07T04:51:07.817Z","sources":[{"name":"CVE","url":"https://www.cve.org/CVERecord?id=CVE-2026-17402"}]}}