{"id":"CVE-2026-104308","aliases":[],"cve":{"records":[{"id":"CVE-2026-104308","source":"ibm","state":"PUBLISHED","reasons":[],"replacements":[],"disputed":false,"unsupportedWhenAssigned":false,"reserved":"2026-10-01T19:22:55.199Z","published":"2026-10-29T15:18:06.244Z","modified":"2026-10-29T15:18:06.244Z"}],"publishers":[{"name":"ibm","role":"CNA","organizationId":"9a959283-ebb5-44b6-b705-dcc2bbced522","modified":"2026-10-29T15:18:06.244Z"}],"references":[{"url":"https://www.ibm.com/support/pages/node/7293015","tags":["vendor-advisory","patch"],"source":"ibm"}],"weaknesses":[{"id":"CWE-78","description":"CWE-78 Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')","source":"ibm"}],"applicability":[],"prioritization":[]},"title":"Langflow OSS is affected by multiple vulnerabilities","titleSource":"ibm","descriptionSource":"ibm","description":"IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to cause a denial of service due to improper neutralization of special elements used in an OS command.","score":4.3,"severity":"medium","published":"2026-10-29T15:18:06.244Z","modified":"2026-10-29T15:18:06.244Z","withdrawn":false,"knownExploited":false,"affected":[],"products":[{"vendor":"IBM","name":"Langflow OSS","platforms":[],"versions":[{"version":"1.0.0","status":"affected","lessThanOrEqual":"1.12.3","versionType":"semver"}],"cpes":["cpe:2.3:a:ibm:langflow_oss:1.0.0:*:*:*:*:*:*:*","cpe:2.3:a:ibm:langflow_oss:1.12.3:*:*:*:*:*:*:*"],"source":"ibm","url":"https://www.cve.org/CVERecord?id=CVE-2026-104308"}],"remediation":[{"text":"IBM strongly recommends addressing the vulnerability now by upgrading  Langflow OSS to version 1.12.4. https://pypi.org/project/langflow/1.12.4/ \n\n\n\nFor Langflow OSS versions 1.0.0 - 1.12.3, follow the  Prepare to upgrade instructions and release-specific configuration changes https://docs.langflow.org/release-notes , including backing up your existing installation, then follow the  Langflow OSS installation instructions https://docs.langflow.org/get-started-installation  to install version 1.12.4 and test your flows.","source":"ibm","url":"https://www.cve.org/CVERecord?id=CVE-2026-104308"}],"references":["https://www.ibm.com/support/pages/node/7293015"],"sources":[{"name":"CVE","id":"CVE-2026-104308","modified":"2026-10-29T15:18:06.244Z","url":"https://www.cve.org/CVERecord?id=CVE-2026-104308"}],"assessments":[{"source":"ibm","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","score":4.3}],"sourceAffected":[],"observedAt":"2026-10-29T15:47:13.321Z","kev":{"status":"not-listed","checkedAt":"2026-10-31T14:10:32.801Z"},"coverage":[{"source":"NVD","status":"not-checked"},{"source":"GHSA","status":"not-checked"},{"source":"EUVD","status":"not-checked"},{"source":"EPSS","status":"not-checked"}],"evidence":[],"aiSummary":{"text":"IBM Langflow OSS versions 1.0.0 through 1.12.3 may allow a remote authenticated attacker to cause a denial of service due to improper neutralization of special elements used in an OS command. The weakness is described as OS Command Injection. The impact is a denial of service.","model":"@cf/meta/llama-3.3-70b-instruct-fp8-fast","generatedAt":"2026-10-30T10:18:34.145Z","sources":[{"name":"CVE","url":"https://www.cve.org/CVERecord?id=CVE-2026-104308"}]}}