lgsl Stored Cross-Site Scripting vulnerability
The advisory, in context
Summary
A stored cross-site scripting (XSS) vulnerability was identified in lgsl. The issue arises from improper sanitation of user input. Everyone who accesses this page will be affected by this attack.
Details
The function lgsl_query_40 in lgsl_protocol.php has implemented an HTTP crawler. This function makes a request to the registered game server, and upon crawling the malicious /info endpoint with our payload, will render our javascript on the info page. This information is being displayed via lgsl_details.php
Affected Code:
foreach ($server['e'] as $field => $value) {
$value = preg_replace('/((https*:\/\/|https*:\/\/www\.|www\.)[\w\d\.\-\/=$?]*)/i', "<a href='$1' target='_blank'>$1</a>", html_entity_decode($value));
$output .= "
<tr><td> {$field} </td><td> {$value} </td></tr>";
}
PoC
-
Create a game server with type
ecoand set the target host and port accordingly to your ttack server. I have crafted this json payload that is being parsed according to the schema and being served on/info -
Serve the following JSON payload at
/infoon your handler
{
"Animals": "1",
"EconomyDesc": "<img src=x onerror=prompt(1)>"
}
- Access the corresponding server info page at
/s?=. Upon refreshing & crawling our server, it should execute our javascript.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 7.0.0
Fixed in 7.0.0
10 explicitly affected versions
v5.10.0, v5.10.1, v5.10.2, v5.10.3, v6.0.0, v6.0.1, v6.1.0, v6.1.1, v6.2.0, v6.2.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "7.0.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v5.10.0",
"v5.10.1",
"v5.10.2",
"v5.10.3",
"v6.0.0",
"v6.0.1",
"v6.1.0",
"v6.1.1",
"v6.2.0",
"v6.2.1"
]
}