GHSA-xx7m-8rq2-cw2vmedium5.4
TYPO3 CMS indexed search Cross-site Scripting vulnerability
The advisory, in context
Cross-site scripting (XSS) vulnerability in the search result view in the Indexed Search (indexed_search) component in TYPO3 6.2.x before 6.2.16 allows remote authenticated editors to inject arbitrary web script or HTML via unspecified vectors.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
typo3/cms Packagist
Ecosystem versions
From 6.2.0 before 6.2.16
Fixed in 6.2.16
17 explicitly affected versions
6.2.0, 6.2.1, 6.2.10, 6.2.10-rc1, 6.2.11, 6.2.12, 6.2.13, 6.2.14, 6.2.15, 6.2.2, 6.2.3, 6.2.4, 6.2.5, 6.2.6, 6.2.7, 6.2.8, 6.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.2.0"
},
{
"fixed": "6.2.16"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"6.2.0",
"6.2.1",
"6.2.10",
"6.2.10-rc1",
"6.2.11",
"6.2.12",
"6.2.13",
"6.2.14",
"6.2.15",
"6.2.2",
"6.2.3",
"6.2.4",
"6.2.5",
"6.2.6",
"6.2.7",
"6.2.8",
"6.2.9"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2015-8756
- https://github.com/TYPO3/typo3/commit/7e4bdf48988191043a65880c72190c4130c1f0e0
- https://github.com/TYPO3-CMS/indexed_search
- https://typo3.org/security/advisory/typo3-core-sa-2015-015
- https://web.archive.org/web/20160624215319/http://www.securitytracker.com/id/1034486