CakePHP vulnerable to Cross-site Scripting in some development error pages
The advisory, in context
CakePHP 3.4 prior to 3.4.14, 3.5 prior to 3.5.17, and 3.6 prior to 3.6.4 contains a cross-site-scripting (XSS) vulnerability in the development only missing route and duplicate named route error pages.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.4.0 before 3.4.14
Fixed in 3.4.14
14 explicitly affected versions
3.4.0, 3.4.1, 3.4.10, 3.4.11, 3.4.12, 3.4.13, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.4.6, 3.4.7, 3.4.8, 3.4.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.4.0"
},
{
"fixed": "3.4.14"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.4.0",
"3.4.1",
"3.4.10",
"3.4.11",
"3.4.12",
"3.4.13",
"3.4.2",
"3.4.3",
"3.4.4",
"3.4.5",
"3.4.6",
"3.4.7",
"3.4.8",
"3.4.9"
]
}From 3.5.0 before 3.5.17
Fixed in 3.5.17
17 explicitly affected versions
3.5.0, 3.5.1, 3.5.10, 3.5.11, 3.5.12, 3.5.13, 3.5.14, 3.5.15, 3.5.16, 3.5.2, 3.5.3, 3.5.4, 3.5.5, 3.5.6, 3.5.7, 3.5.8, 3.5.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.5.0"
},
{
"fixed": "3.5.17"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.5.0",
"3.5.1",
"3.5.10",
"3.5.11",
"3.5.12",
"3.5.13",
"3.5.14",
"3.5.15",
"3.5.16",
"3.5.2",
"3.5.3",
"3.5.4",
"3.5.5",
"3.5.6",
"3.5.7",
"3.5.8",
"3.5.9"
]
}From 3.6.0 before 3.6.4
Fixed in 3.6.4
4 explicitly affected versions
3.6.0, 3.6.1, 3.6.2, 3.6.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.6.0"
},
{
"fixed": "3.6.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.6.0",
"3.6.1",
"3.6.2",
"3.6.3"
]
}