GHSA-xwf2-53mc-r8hxhigh8.8
phpMyAdmin CSRF Vulnerability
The advisory, in context
phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 4.8 before 4.8.4
Fixed in 4.8.4
5 explicitly affected versions
4.8.0, 4.8.0.1, 4.8.1, 4.8.2, 4.8.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.8"
},
{
"fixed": "4.8.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.8.0",
"4.8.0.1",
"4.8.1",
"4.8.2",
"4.8.3"
]
}phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 4.7 through 4.7.6 (inclusive)
No fix recorded for this interval.
7 explicitly affected versions
4.7.0, 4.7.1, 4.7.2, 4.7.3, 4.7.4, 4.7.5, 4.7.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.7"
},
{
"last_affected": "4.7.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.7.0",
"4.7.1",
"4.7.2",
"4.7.3",
"4.7.4",
"4.7.5",
"4.7.6"
]
}