GHSA-xvvv-wj7j-r9jmmedium6.1
Cross-site Scripting in Netgen Tags Bundle
The advisory, in context
Netgen Tags Bundle 3.4.x before 3.4.11 and 4.0.x before 4.0.15 allows XSS in the Tags Admin interface.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
netgen/tagsbundle Packagist
Ecosystem versions
From 3.4.0 before 3.4.11
Fixed in 3.4.11
11 explicitly affected versions
3.4.0, 3.4.1, 3.4.10, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.4.6, 3.4.7, 3.4.8, 3.4.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.4.0"
},
{
"fixed": "3.4.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.4.0",
"3.4.1",
"3.4.10",
"3.4.2",
"3.4.3",
"3.4.4",
"3.4.5",
"3.4.6",
"3.4.7",
"3.4.8",
"3.4.9"
]
}netgen/tagsbundle Packagist
Ecosystem versions
From 4.0.0 before 4.0.15
Fixed in 4.0.15
15 explicitly affected versions
4.0.0, 4.0.1, 4.0.10, 4.0.11, 4.0.12, 4.0.13, 4.0.14, 4.0.2, 4.0.3, 4.0.4, 4.0.5, 4.0.6, 4.0.7, 4.0.8, 4.0.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.0.15"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.0",
"4.0.1",
"4.0.10",
"4.0.11",
"4.0.12",
"4.0.13",
"4.0.14",
"4.0.2",
"4.0.3",
"4.0.4",
"4.0.5",
"4.0.6",
"4.0.7",
"4.0.8",
"4.0.9"
]
}