Moodle Login CSRF vulnerability in login form
The advisory, in context
A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier. The login form is not protected by a token to prevent login cross-site request forgery. Fixed versions include 3.6, 3.5.3, 3.4.6, 3.3.9 and 3.1.15.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.1 before 3.1.15
Fixed in 3.1.15
18 explicitly affected versions
v3.1.0, v3.1.0-beta, v3.1.0-rc1, v3.1.0-rc2, v3.1.1, v3.1.10, v3.1.11, v3.1.12, v3.1.13, v3.1.14, v3.1.2, v3.1.3, v3.1.4, v3.1.5, v3.1.6, v3.1.7, v3.1.8, v3.1.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.1"
},
{
"fixed": "3.1.15"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.1.0",
"v3.1.0-beta",
"v3.1.0-rc1",
"v3.1.0-rc2",
"v3.1.1",
"v3.1.10",
"v3.1.11",
"v3.1.12",
"v3.1.13",
"v3.1.14",
"v3.1.2",
"v3.1.3",
"v3.1.4",
"v3.1.5",
"v3.1.6",
"v3.1.7",
"v3.1.8",
"v3.1.9"
]
}From 3.3 before 3.3.9
Fixed in 3.3.9
13 explicitly affected versions
v3.3.0, v3.3.0-beta, v3.3.0-rc1, v3.3.0-rc2, v3.3.0-rc3, v3.3.1, v3.3.2, v3.3.3, v3.3.4, v3.3.5, v3.3.6, v3.3.7, v3.3.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.3"
},
{
"fixed": "3.3.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.3.0",
"v3.3.0-beta",
"v3.3.0-rc1",
"v3.3.0-rc2",
"v3.3.0-rc3",
"v3.3.1",
"v3.3.2",
"v3.3.3",
"v3.3.4",
"v3.3.5",
"v3.3.6",
"v3.3.7",
"v3.3.8"
]
}From 3.4 before 3.4.6
Fixed in 3.4.6
10 explicitly affected versions
v3.4.0, v3.4.0-beta, v3.4.0-rc1, v3.4.0-rc2, v3.4.0-rc3, v3.4.1, v3.4.2, v3.4.3, v3.4.4, v3.4.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.4"
},
{
"fixed": "3.4.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.4.0",
"v3.4.0-beta",
"v3.4.0-rc1",
"v3.4.0-rc2",
"v3.4.0-rc3",
"v3.4.1",
"v3.4.2",
"v3.4.3",
"v3.4.4",
"v3.4.5"
]
}From 3.5 before 3.5.3
Fixed in 3.5.3
5 explicitly affected versions
v3.5.0, v3.5.0-beta, v3.5.0-rc1, v3.5.1, v3.5.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.5"
},
{
"fixed": "3.5.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.5.0",
"v3.5.0-beta",
"v3.5.0-rc1",
"v3.5.1",
"v3.5.2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-16854
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16854
- https://github.com/moodle/moodle
- https://moodle.org/mod/forum/discuss.php?d=378731
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-63183
- http://www.securityfocus.com/bid/106017
- http://www.securitytracker.com/id/1042154