GHSA-xj4v-gp4q-h6qqmedium6.1
qcubed reflected cross-site scripting (XSS) vulnerability
The advisory, in context
A reflected cross-site scripting (XSS) vulnerability in qcubed (all versions including 3.1.1) in profile.php via the stQuery-parameter allows unauthenticated attackers to steal sessions of authenticated users.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
qcubed/qcubed Packagist
Ecosystem versions
Earlier releases before 3.2
Fixed in 3.2
11 explicitly affected versions
v3.0.1-beta, v3.0.2-beta, v3.0.3-beta, v3.0.4-beta, v3.0.5-beta, v3.0.6, v3.0.7, v3.0.8, v3.0.9, v3.1.0, v3.1.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.0.1-beta",
"v3.0.2-beta",
"v3.0.3-beta",
"v3.0.4-beta",
"v3.0.5-beta",
"v3.0.6",
"v3.0.7",
"v3.0.8",
"v3.0.9",
"v3.1.0",
"v3.1.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2020-24912
- https://github.com/qcubed/qcubed/pull/1320/files
- https://github.com/qcubed/qcubed
- https://tech.feedyourhead.at/content/QCubed-Cross-Site-Scripting-CVE-2020-24912
- https://www.ait.ac.at/themen/cyber-security/pentesting/security-advisories/ait-sa-20210215-03
- http://qcubed.com
- http://seclists.org/fulldisclosure/2021/Mar/30