ExecuTorch vulnerable to Heap-based Buffer Overflow
The advisory, in context
A group of related buffer overflow vulnerabilities in the loading of ExecuTorch models can cause the runtime to crash and potentially result in code execution or other undesirable effects. This issue affects ExecuTorch prior to commit cea9b23aa8ff78aff92829a466da97461cc7930c.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 0.7.0
Fixed in 0.7.0
8 explicitly affected versions
0.1.0, 0.1.2, 0.2.0, 0.2.1, 0.3.0, 0.4.0, 0.5.0, 0.6.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "0.7.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.1.0",
"0.1.2",
"0.2.0",
"0.2.1",
"0.3.0",
"0.4.0",
"0.5.0",
"0.6.0"
]
}Earlier releases before 0.7.0
Fixed in 0.7.0
10 explicitly affected versions
0.5.0, 0.5.1, 0.6.0, 0.6.0-rc1, 0.6.0-rc3, 0.6.0-rc4, 0.6.0-rc6, 0.7.0-rc1, 0.7.0-rc2, 0.7.0-rc5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "0.7.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.5.0",
"0.5.1",
"0.6.0",
"0.6.0-rc1",
"0.6.0-rc3",
"0.6.0-rc4",
"0.6.0-rc6",
"0.7.0-rc1",
"0.7.0-rc2",
"0.7.0-rc5"
]
}Earlier releases before 0.7.0
Fixed in 0.7.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "0.7.0"
}
],
"type": "SEMVER"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2025-54951
- https://github.com/pytorch/executorch/commit/cea9b23aa8ff78aff92829a466da97461cc7930c
- https://github.com/pypa/advisory-database/tree/main/vulns/executorch/PYSEC-2026-336.yaml
- https://github.com/pytorch/executorch
- https://pypi.org/project/executorch
- https://www.facebook.com/security/advisories/cve-2025-54951