GHSA-xc69-p8fc-m6m5high8.8No CVE assigned
silverstripe/subsites Unsafe SQL Query Construction (Safe Data Source)
Impact
There is a low level potential SQL injection vulnerability in the silverstripe/subsites module has been identified and fixed in version 2.1.1.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
silverstripe/subsites Packagist
| Affected range | Recorded fix |
|---|---|
| From 2.0.0 before 2.1.1Ecosystem versions | 2.1.1 |
Version evidence: OSV · GHSA-xc69-p8fc-m6m5
View original version evidence (4 explicit versions)
Original source description
There is a low level potential SQL injection vulnerability in the silverstripe/subsites module has been identified and fixed in version 2.1.1.
References
- Patch github.com/silverstripe/silverstripe-subsites/commit/bf2c81dce62ae9a7623d224fd31a39505260eb57
- Security advisory github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/subsites/SS-2018-016-1.yaml
- Source reference github.com/silverstripe/silverstripe-subsites
- Security advisory www.silverstripe.org/download/security-releases/ss-2018-016