Magento Improper Access Control vulnerability
The advisory, in context
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in Privilege escalation. An attacker with a low privilege account could leverage this vulnerability to perform an account takeover for a victim. Exploitation of this issue does not require user interaction.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 2.3.0 before 2.3.7-p4
Fixed in 2.3.7-p4
17 explicitly affected versions
2.3.0, 2.3.1, 2.3.2, 2.3.2-p2, 2.3.3, 2.3.3-p1, 2.3.4, 2.3.4-p2, 2.3.5, 2.3.5-p1, 2.3.5-p2, 2.3.6, 2.3.6-p1, 2.3.7, 2.3.7-p1, 2.3.7-p2, 2.3.7-p3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.3.0"
},
{
"fixed": "2.3.7-p4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.3.0",
"2.3.1",
"2.3.2",
"2.3.2-p2",
"2.3.3",
"2.3.3-p1",
"2.3.4",
"2.3.4-p2",
"2.3.5",
"2.3.5-p1",
"2.3.5-p2",
"2.3.6",
"2.3.6-p1",
"2.3.7",
"2.3.7-p1",
"2.3.7-p2",
"2.3.7-p3"
]
}From 2.4.4 before 2.4.5
Fixed in 2.4.5
14 explicitly affected versions
2.4.4, 2.4.4-p1, 2.4.4-p10, 2.4.4-p11, 2.4.4-p12, 2.4.4-p13, 2.4.4-p2, 2.4.4-p3, 2.4.4-p4, 2.4.4-p5, 2.4.4-p6, 2.4.4-p7, 2.4.4-p8, 2.4.4-p9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.4.4"
},
{
"fixed": "2.4.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.4.4",
"2.4.4-p1",
"2.4.4-p10",
"2.4.4-p11",
"2.4.4-p12",
"2.4.4-p13",
"2.4.4-p2",
"2.4.4-p3",
"2.4.4-p4",
"2.4.4-p5",
"2.4.4-p6",
"2.4.4-p7",
"2.4.4-p8",
"2.4.4-p9"
]
}From 2.4.0 before 2.4.3-p3
Fixed in 2.4.3-p3
10 explicitly affected versions
2.4.0, 2.4.0-p1, 2.4.1, 2.4.1-p1, 2.4.2, 2.4.2-p1, 2.4.2-p2, 2.4.3, 2.4.3-p1, 2.4.3-p2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.4.0"
},
{
"fixed": "2.4.3-p3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.4.0",
"2.4.0-p1",
"2.4.1",
"2.4.1-p1",
"2.4.2",
"2.4.2-p1",
"2.4.2-p2",
"2.4.3",
"2.4.3-p1",
"2.4.3-p2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-34255
- https://github.com/magento/magento2/commit/246d524b7586af2245092008e0d92b8d6fdd8523
- https://github.com/magento/magento2/commit/5548bc64b5bc904346c0af9193a7fbb5274b4efa
- https://github.com/magento/magento2/commit/5f07eba878296a37bd5c3a2baecad48948547594
- https://github.com/magento/magento2
- https://helpx.adobe.com/security/products/magento/apsb22-38.html