GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-x93q-x9pc-w5hwmedium5.4

Paymenter has broken object level authorization via service reference manipulation on ticket creation

Check your stack

The advisory, in context

Summary

The ticket creation endpoint accepts a user-supplied service identifier without enforcing ownership validation, allowing authenticated users to create support tickets referencing services belonging to other accounts by modifying the service ID in the request.

Technical Details

The ticket creation endpoint accepted a user-supplied service identifier without verifying ownership or authorization against the authenticated account. An attacker could modify the service ID value in the client-side request and successfully create a ticket associated with another user's service.

The vulnerability required authentication and did not provide direct access to service contents or customer data. However, referenced service information could become visible to support personnel handling the ticket.

Impact

Successful exploitation could allow an authenticated user to:

  • Create support tickets referencing services belonging to other users
  • Potentially cause support staff to interact with or review unrelated customer services

The vulnerability did not allow:

  • Direct access to another user's service
  • Modification of another user's service
  • Retrieval of confidential service data through the vulnerable endpoint itself

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

Earlier releases before 1.5.0

Fixed in 1.5.0

32 explicitly affected versions

0.1, 0.1.1, 0.1.2, 0.1.3, 0.2, 0.2.1, v0.3, v0.4, v0.4.1, v0.5, v0.5.1, v0.5.2, v0.5.3, v0.6, v0.7, v0.7.1, v0.8, v0.8.1, v0.8.2, v0.9, v0.9.1, v0.9.2, v0.9.3, v0.9.4, v0.9.5, v1.0.0, v1.0.1, v1.0.2, v1.0.3, v1.0.4, v1.1.0, v1.1.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "1.5.0"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "0.1",
    "0.1.1",
    "0.1.2",
    "0.1.3",
    "0.2",
    "0.2.1",
    "v0.3",
    "v0.4",
    "v0.4.1",
    "v0.5",
    "v0.5.1",
    "v0.5.2",
    "v0.5.3",
    "v0.6",
    "v0.7",
    "v0.7.1",
    "v0.8",
    "v0.8.1",
    "v0.8.2",
    "v0.9",
    "v0.9.1",
    "v0.9.2",
    "v0.9.3",
    "v0.9.4",
    "v0.9.5",
    "v1.0.0",
    "v1.0.1",
    "v1.0.2",
    "v1.0.3",
    "v1.0.4",
    "v1.1.0",
    "v1.1.1"
  ]
}

References