GHSA-x86x-qhf8-f37wcritical9.8
willdurand/js-translation-bundle potential path traversal attack and remote code injection
No CVE assignedCheck your stack
The advisory, in context
A path traversal and a javascript code injection vulnerabilities were identified in willdurand/js-translation-bundle versions prior to 2.1.1.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
willdurand/js-translation-bundle Packagist
Ecosystem versions
Earlier releases before 2.1.1
Fixed in 2.1.1
28 explicitly affected versions
0.0.1, 0.0.2, 0.0.3, 0.0.4, 0.0.5, 0.1.0, 0.1.1, 0.1.2, 0.1.3, 0.2.0, 0.2.1, 0.3.0, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.1.0, 1.1.1, 1.1.2, 1.2.0, 1.2.1, 1.2.2, v2.0.0, v2.0.0-alpha1, v2.0.0-alpha2, v2.0.0-alpha3, v2.0.0-alpha4, v2.1.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.1.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.0.1",
"0.0.2",
"0.0.3",
"0.0.4",
"0.0.5",
"0.1.0",
"0.1.1",
"0.1.2",
"0.1.3",
"0.2.0",
"0.2.1",
"0.3.0",
"1.0.0",
"1.0.1",
"1.0.2",
"1.0.3",
"1.1.0",
"1.1.1",
"1.1.2",
"1.2.0",
"1.2.1",
"1.2.2",
"v2.0.0",
"v2.0.0-alpha1",
"v2.0.0-alpha2",
"v2.0.0-alpha3",
"v2.0.0-alpha4",
"v2.1.0"
]
}References
- https://github.com/willdurand/BazingaJsTranslationBundle/commit/7accee93569c3f3d2379f035a41ece66522801fc
- https://github.com/willdurand/BazingaJsTranslationBundle/commit/df6c0fd603c0192ebc5584991a52a1092c5f60bd
- https://github.com/FriendsOfPHP/security-advisories/blob/master/willdurand/js-translation-bundle/2014-07-29-1.yaml
- https://github.com/willdurand/BazingaJsTranslationBundle
- https://github.com/willdurand/BazingaJsTranslationBundle/releases/tag/v2.1.1