GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-x82r-6j37-vrgglow1.8

Pimcore's Admin Classic Bundle allows HTML Injection

Check your stack

The advisory, in context

Summary

An HTML injection issue allows users with access to the email sending functionality to inject arbitrary HTML code into emails sent via the admin interface, potentially leading to session cookie theft and the alteration of page content.

Details

The vulnerability was discovered in the /admin/email/send-test-email endpoint using the POST method. The vulnerable parameter is content, which permits the injection of arbitrary HTML code during the email sending process. While JavaScript code injection is blocked through filtering, HTML code injection remains possible.

PoC

To reproduce the vulnerability, a user must fill out the email's content form with the desired HTML payload. send-test-mail-text

Impact

mail-text

This HTML injection vulnerability can potentially enable phishing attacks by allowing the insertion of any html like fake login forms, etc. All functionalities that process user input should be carefully reviewed to ensure that data is appropriately encoded as HTML entities in server responses. For instance, a reflected input paramete like <h1> just a test </h1> <p> <img> should be displayed in the HTML response as &#x3c;h1&#x3e; just a test &#x3c;/h1&#x3e; &#x3c;p&#x3e; &#x3c;img&#x3e;.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

Earlier releases before 1.7.6

Fixed in 1.7.6

57 explicitly affected versions

1.4.0, v1.0.0, v1.0.0-BETA1, v1.0.0-RC1, v1.0.0-RC2, v1.0.1, v1.0.2, v1.0.3, v1.0.4, v1.0.5, v1.0.6, v1.1.0, v1.1.0-RC1, v1.1.1, v1.1.2, v1.1.3, v1.1.4, v1.2, v1.2.0-RC1, v1.2.1, v1.2.2, v1.2.3, v1.3.0, v1.3.0-RC1, v1.3.1, v1.3.2, v1.3.3, v1.3.4, v1.3.5, v1.4.1, v1.4.2, v1.4.3, v1.4.4, v1.4.5, v1.5.0, v1.5.0-RC1, v1.5.0-RC2, v1.5.1, v1.5.2, v1.5.3, v1.5.4, v1.5.5, v1.6.0, v1.6.0-RC1, v1.6.0-RC2, v1.6.1, v1.6.2, v1.6.3, v1.6.4, v1.6.5, v1.6.6, v1.7.0, v1.7.1, v1.7.2, v1.7.3, v1.7.4, v1.7.5

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "1.7.6"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "1.4.0",
    "v1.0.0",
    "v1.0.0-BETA1",
    "v1.0.0-RC1",
    "v1.0.0-RC2",
    "v1.0.1",
    "v1.0.2",
    "v1.0.3",
    "v1.0.4",
    "v1.0.5",
    "v1.0.6",
    "v1.1.0",
    "v1.1.0-RC1",
    "v1.1.1",
    "v1.1.2",
    "v1.1.3",
    "v1.1.4",
    "v1.2",
    "v1.2.0-RC1",
    "v1.2.1",
    "v1.2.2",
    "v1.2.3",
    "v1.3.0",
    "v1.3.0-RC1",
    "v1.3.1",
    "v1.3.2",
    "v1.3.3",
    "v1.3.4",
    "v1.3.5",
    "v1.4.1",
    "v1.4.2",
    "v1.4.3",
    "v1.4.4",
    "v1.4.5",
    "v1.5.0",
    "v1.5.0-RC1",
    "v1.5.0-RC2",
    "v1.5.1",
    "v1.5.2",
    "v1.5.3",
    "v1.5.4",
    "v1.5.5",
    "v1.6.0",
    "v1.6.0-RC1",
    "v1.6.0-RC2",
    "v1.6.1",
    "v1.6.2",
    "v1.6.3",
    "v1.6.4",
    "v1.6.5",
    "v1.6.6",
    "v1.7.0",
    "v1.7.1",
    "v1.7.2",
    "v1.7.3",
    "v1.7.4",
    "v1.7.5"
  ]
}

References