Drupal Core Arbitrary PHP code execution vulnerability
The advisory, in context
Arbitrary PHP code execution vulnerability in Drupal Core under certain circumstances. An attacker could trick an administrator into visiting a malicious site that could result in creating a carefully named directory on the file system. With this directory in place, an attacker could attempt to brute force a remote code execution vulnerability. Windows servers are most likely to be affected. This issue affects: Drupal Drupal Core 8.8.x versions prior to 8.8.8; 8.9.x versions prior to 8.9.1; 9.0.1 versions prior to 9.0.1.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 8.8.0 before 8.8.8
Fixed in 8.8.8
8 explicitly affected versions
8.8.0, 8.8.1, 8.8.2, 8.8.3, 8.8.4, 8.8.5, 8.8.6, 8.8.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.8.0"
},
{
"fixed": "8.8.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.8.0",
"8.8.1",
"8.8.2",
"8.8.3",
"8.8.4",
"8.8.5",
"8.8.6",
"8.8.7"
]
}From 8.9.0 before 8.9.1
Fixed in 8.9.1
1 explicitly affected versions
8.9.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.9.0"
},
{
"fixed": "8.9.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.9.0"
]
}From 9.0.0 before 9.0.1
Fixed in 9.0.1
1 explicitly affected versions
9.0.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "9.0.0"
},
{
"fixed": "9.0.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"9.0.0"
]
}From 8.8.0 before 8.8.8
Fixed in 8.8.8
8 explicitly affected versions
8.8.0, 8.8.1, 8.8.2, 8.8.3, 8.8.4, 8.8.5, 8.8.6, 8.8.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.8.0"
},
{
"fixed": "8.8.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.8.0",
"8.8.1",
"8.8.2",
"8.8.3",
"8.8.4",
"8.8.5",
"8.8.6",
"8.8.7"
]
}From 8.9.0 before 8.9.1
Fixed in 8.9.1
1 explicitly affected versions
8.9.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.9.0"
},
{
"fixed": "8.9.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.9.0"
]
}From 9.0.0 before 9.0.1
Fixed in 9.0.1
1 explicitly affected versions
9.0.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "9.0.0"
},
{
"fixed": "9.0.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"9.0.0"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2020-13664
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2020-13664.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2020-13664.yaml
- https://github.com/drupal/core
- https://www.drupal.org/sa-core-2020-005