Login by Auth0 plugin for WordPress vulnerable to Reflected Cross-Site Scripting
The advisory, in context
Impact
The Auth0 WordPress plugin allows site administrators to opt-in to allowing the use of a wle parameter, which can be passed to the WordPress login page by end users. When this parameter is supplied using an expected value (which is randomly generated by the plugin, by default), the end user can fallback to using WordPress' native authentication behavior. (This is generally intended as an emergency fallback for administrators to still be able to access their dashboard in the event something goes wrong.)
In previous versions of the plugin, under specific conditions, this parameter could potentially accept an arbitrary string that would be improperly rendered, potentially allowing for a cross-site scripting (XSS) attack on the login page.
Patches
Please upgrade to v4.6.1 of the plugin to resolve the issue.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 4.6.1
Fixed in 4.6.1
57 explicitly affected versions
2.0.0, 2.1.0, 2.1.1, 2.1.11, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7, 2.1.8, 2.1.9, 2.2.0, 3.1.1, 3.1.2, 3.1.3, 3.1.4, 3.10.0, 3.11.0, 3.11.1, 3.11.2, 3.11.3, 3.2.0, 3.2.10, 3.2.14, 3.2.19, 3.2.21, 3.2.22, 3.2.23, 3.2.24, 3.2.25, 3.2.5, 3.2.8, 3.2.9, 3.3.2, 3.4.0, 3.5.0, 3.5.1, 3.5.2, 3.6.0, 3.6.1, 3.6.2, 3.7.0, 3.7.1, 3.7.3, 3.8.0, 3.8.1, 3.9.0, 4.0.0, 4.1.0, 4.1.1, 4.2.0, 4.3.0, 4.3.1, 4.4.0, 4.5.0, 4.6.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "4.6.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.0",
"2.1.0",
"2.1.1",
"2.1.11",
"2.1.2",
"2.1.3",
"2.1.4",
"2.1.5",
"2.1.6",
"2.1.7",
"2.1.8",
"2.1.9",
"2.2.0",
"3.1.1",
"3.1.2",
"3.1.3",
"3.1.4",
"3.10.0",
"3.11.0",
"3.11.1",
"3.11.2",
"3.11.3",
"3.2.0",
"3.2.10",
"3.2.14",
"3.2.19",
"3.2.21",
"3.2.22",
"3.2.23",
"3.2.24",
"3.2.25",
"3.2.5",
"3.2.8",
"3.2.9",
"3.3.2",
"3.4.0",
"3.5.0",
"3.5.1",
"3.5.2",
"3.6.0",
"3.6.1",
"3.6.2",
"3.7.0",
"3.7.1",
"3.7.3",
"3.8.0",
"3.8.1",
"3.9.0",
"4.0.0",
"4.1.0",
"4.1.1",
"4.2.0",
"4.3.0",
"4.3.1",
"4.4.0",
"4.5.0",
"4.6.0"
]
}References
- https://github.com/auth0/wordpress/security/advisories/GHSA-x6p7-44rh-m3rr
- https://nvd.nist.gov/vuln/detail/CVE-2023-6813
- https://github.com/auth0/wordpress
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3114611%40auth0&new=3114611%40auth0&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0c4e0d48-fde1-45dd-8e06-4582cf677579?source=cve