GHSA-x6mh-rjwm-8ph7medium6.8
Cross-site Scripting vulnerability in SimpleXLSXEx::readXfs and SimpeXLSX::toHTMLEx
The advisory, in context
Impact
When calling the extended toHTMLEx method, it is possible to execute arbitrary JavaScript code.
Patches
The supplied patch resolves this vulnerability for SimpleXLSX. Use 1.1.12
Workarounds
Don't use direct publication via toHTMLEx
This vulnerability was discovered by Aleksey Solovev (Positive Technologies)
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
shuchkin/simplexlsx Packagist
Ecosystem versions
From 1.0.12 before 1.1.12
Fixed in 1.1.12
12 explicitly affected versions
1.0.12, 1.0.13, 1.0.14, 1.0.15, 1.0.16, 1.0.17, 1.0.18, 1.0.19, 1.0.20, 1.0.21, 1.1.10, 1.1.11
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.0.12"
},
{
"fixed": "1.1.12"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.12",
"1.0.13",
"1.0.14",
"1.0.15",
"1.0.16",
"1.0.17",
"1.0.18",
"1.0.19",
"1.0.20",
"1.0.21",
"1.1.10",
"1.1.11"
]
}