Improper Certificate Validation in apache airflow mongo hook
The advisory, in context
When ssl was enabled for Mongo Hook, default settings included "allow_insecure" which caused that certificates were not validated. This was unexpected and undocumented. Users are recommended to upgrade to version 4.0.0, which fixes this issue.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 4.0.0
Fixed in 4.0.0
45 explicitly affected versions
1.0.0, 1.0.0b1, 1.0.0b2, 1.0.0rc1, 1.0.1, 1.0.1rc1, 2.0.0, 2.0.0rc1, 2.0.0rc2, 2.1.0, 2.1.0rc1, 2.2.0, 2.2.0rc1, 2.3.0, 2.3.0rc1, 2.3.1, 2.3.1rc1, 2.3.2, 2.3.2rc1, 2.3.3, 2.3.3rc1, 3.0.0, 3.0.0rc1, 3.0.0rc2, 3.1.0, 3.1.0rc1, 3.1.1, 3.1.1rc1, 3.2.0, 3.2.0rc1, 3.2.0rc2, 3.2.1, 3.2.1rc1, 3.2.2, 3.2.2rc1, 3.3.0, 3.3.0rc1, 3.4.0, 3.4.0rc1, 3.5.0, 3.5.0rc1, 3.6.0, 3.6.0rc1, 3.6.0rc2, 4.0.0rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "4.0.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.0",
"1.0.0b1",
"1.0.0b2",
"1.0.0rc1",
"1.0.1",
"1.0.1rc1",
"2.0.0",
"2.0.0rc1",
"2.0.0rc2",
"2.1.0",
"2.1.0rc1",
"2.2.0",
"2.2.0rc1",
"2.3.0",
"2.3.0rc1",
"2.3.1",
"2.3.1rc1",
"2.3.2",
"2.3.2rc1",
"2.3.3",
"2.3.3rc1",
"3.0.0",
"3.0.0rc1",
"3.0.0rc2",
"3.1.0",
"3.1.0rc1",
"3.1.1",
"3.1.1rc1",
"3.2.0",
"3.2.0rc1",
"3.2.0rc2",
"3.2.1",
"3.2.1rc1",
"3.2.2",
"3.2.2rc1",
"3.3.0",
"3.3.0rc1",
"3.4.0",
"3.4.0rc1",
"3.5.0",
"3.5.0rc1",
"3.6.0",
"3.6.0rc1",
"3.6.0rc2",
"4.0.0rc1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2024-25141
- https://github.com/apache/airflow/pull/37214
- https://github.com/apache/airflow
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-mongo/PYSEC-2026-278.yaml
- https://lists.apache.org/thread/sqgbfqngjmn45ommmrgj7hvs7fgspsgm
- https://pypi.org/project/apache-airflow-providers-mongo
- http://www.openwall.com/lists/oss-security/2024/02/20/5