GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-x5hj-47vv-53p8medium5.3

YUI Cross-site Scripting (XSS) vulnerability

Check your stack

The advisory, in context

Cross-site scripting (XSS) vulnerability in io.swf in the IO Utility component in Yahoo! YUI 3.10.2, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL. NOTE: this vulnerability exists because of a CVE-2013-4939 regression.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

yui npm
Semantic versions

From 3.0.0 before 3.10.11

Fixed in 3.10.11

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "3.0.0"
        },
        {
          "fixed": "3.10.11"
        }
      ],
      "type": "SEMVER"
    }
  ],
  "versions": []
}
yui npm
Semantic versions

From 3.10.12 before 3.10.13

Fixed in 3.10.13

1 explicitly affected versions

3.10.12

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "3.10.12"
        },
        {
          "fixed": "3.10.13"
        }
      ],
      "type": "SEMVER"
    }
  ],
  "versions": [
    "3.10.12"
  ]
}
Ecosystem versions

Earlier releases before 2.2.11

Fixed in 2.2.11

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "2.2.11"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": []
}
Ecosystem versions

From 2.3.0 before 2.3.8

Fixed in 2.3.8

4 explicitly affected versions

v2.3.4, v2.3.5, v2.3.6, v2.3.7

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "2.3.0"
        },
        {
          "fixed": "2.3.8"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v2.3.4",
    "v2.3.5",
    "v2.3.6",
    "v2.3.7"
  ]
}
Ecosystem versions

From 2.4.0-rc1 before 2.4.5

Fixed in 2.4.5

6 explicitly affected versions

v2.4.0, v2.4.0-rc1, v2.4.1, v2.4.2, v2.4.3, v2.4.4

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "2.4.0-rc1"
        },
        {
          "fixed": "2.4.5"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v2.4.0",
    "v2.4.0-rc1",
    "v2.4.1",
    "v2.4.2",
    "v2.4.3",
    "v2.4.4"
  ]
}
Ecosystem versions

From 2.5.0-beta before 2.5.1

Fixed in 2.5.1

3 explicitly affected versions

v2.5.0, v2.5.0-beta, v2.5.0-rc1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "2.5.0-beta"
        },
        {
          "fixed": "2.5.1"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v2.5.0",
    "v2.5.0-beta",
    "v2.5.0-rc1"
  ]
}

References