Contao Core directory traversal vulnerability
The advisory, in context
A logged in back end user can include arbitrary PHP files by manipulating an URL parameter. Since Contao does not allow to upload PHP files in the file manager, the attack is limited to the existing PHP files on the server.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 4.0.0 before 4.4.1
Fixed in 4.4.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.4.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}From 4.0.0 before 4.4.1
Fixed in 4.4.1
36 explicitly affected versions
4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.1.0, 4.1.0-RC1, 4.1.0-beta1, 4.1.1, 4.1.2, 4.1.3, 4.2.0, 4.2.0-RC1, 4.2.0-beta1, 4.2.1, 4.2.2, 4.2.3, 4.2.4, 4.2.5, 4.3.0, 4.3.0-RC1, 4.3.1, 4.3.10, 4.3.11, 4.3.2, 4.3.3, 4.3.4, 4.3.5, 4.3.6, 4.3.7, 4.3.8, 4.3.9, 4.4.0, 4.4.0-RC1, 4.4.0-RC2, 4.4.0-beta1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.4.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.0",
"4.0.1",
"4.0.2",
"4.0.3",
"4.0.4",
"4.1.0",
"4.1.0-RC1",
"4.1.0-beta1",
"4.1.1",
"4.1.2",
"4.1.3",
"4.2.0",
"4.2.0-RC1",
"4.2.0-beta1",
"4.2.1",
"4.2.2",
"4.2.3",
"4.2.4",
"4.2.5",
"4.3.0",
"4.3.0-RC1",
"4.3.1",
"4.3.10",
"4.3.11",
"4.3.2",
"4.3.3",
"4.3.4",
"4.3.5",
"4.3.6",
"4.3.7",
"4.3.8",
"4.3.9",
"4.4.0",
"4.4.0-RC1",
"4.4.0-RC2",
"4.4.0-beta1"
]
}From 3.0.0 before 3.5.28
Fixed in 3.5.28
89 explicitly affected versions
3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.1.0, 3.1.1, 3.1.2, 3.1.3, 3.1.4, 3.1.5, 3.1.RC1, 3.1.beta1, 3.2.0, 3.2.1, 3.2.10, 3.2.11, 3.2.12, 3.2.13, 3.2.14, 3.2.15, 3.2.16, 3.2.17, 3.2.18, 3.2.19, 3.2.2, 3.2.20, 3.2.21, 3.2.3, 3.2.4, 3.2.5, 3.2.6, 3.2.7, 3.2.8, 3.2.9, 3.2.RC1, 3.2.beta1, 3.2.beta2, 3.3.0, 3.3.0-RC1, 3.3.0-RC2, 3.3.0-beta1, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5, 3.3.6, 3.3.7, 3.4.0, 3.4.0-RC1, 3.4.0-beta1, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.5.0, 3.5.0-RC1, 3.5.0-beta1, 3.5.1, 3.5.10, 3.5.11, 3.5.12, 3.5.13, 3.5.14, 3.5.15, 3.5.16, 3.5.17, 3.5.18, 3.5.19, 3.5.2, 3.5.20, 3.5.21, 3.5.22, 3.5.23, 3.5.24, 3.5.25, 3.5.26, 3.5.27, 3.5.3, 3.5.4, 3.5.5, 3.5.6, 3.5.7, 3.5.8, 3.5.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.5.28"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.0.0",
"3.0.1",
"3.0.2",
"3.0.3",
"3.0.4",
"3.0.5",
"3.0.6",
"3.1.0",
"3.1.1",
"3.1.2",
"3.1.3",
"3.1.4",
"3.1.5",
"3.1.RC1",
"3.1.beta1",
"3.2.0",
"3.2.1",
"3.2.10",
"3.2.11",
"3.2.12",
"3.2.13",
"3.2.14",
"3.2.15",
"3.2.16",
"3.2.17",
"3.2.18",
"3.2.19",
"3.2.2",
"3.2.20",
"3.2.21",
"3.2.3",
"3.2.4",
"3.2.5",
"3.2.6",
"3.2.7",
"3.2.8",
"3.2.9",
"3.2.RC1",
"3.2.beta1",
"3.2.beta2",
"3.3.0",
"3.3.0-RC1",
"3.3.0-RC2",
"3.3.0-beta1",
"3.3.1",
"3.3.2",
"3.3.3",
"3.3.4",
"3.3.5",
"3.3.6",
"3.3.7",
"3.4.0",
"3.4.0-RC1",
"3.4.0-beta1",
"3.4.1",
"3.4.2",
"3.4.3",
"3.4.4",
"3.4.5",
"3.5.0",
"3.5.0-RC1",
"3.5.0-beta1",
"3.5.1",
"3.5.10",
"3.5.11",
"3.5.12",
"3.5.13",
"3.5.14",
"3.5.15",
"3.5.16",
"3.5.17",
"3.5.18",
"3.5.19",
"3.5.2",
"3.5.20",
"3.5.21",
"3.5.22",
"3.5.23",
"3.5.24",
"3.5.25",
"3.5.26",
"3.5.27",
"3.5.3",
"3.5.4",
"3.5.5",
"3.5.6",
"3.5.7",
"3.5.8",
"3.5.9"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2017-10993
- https://contao.org/en/news/contao-3_5_28.html
- https://contao.org/en/news/contao-4_4_1.html
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/contao/CVE-2017-10993.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/core-bundle/CVE-2017-10993.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/core/CVE-2017-10993.yaml