GHSA-x45f-j34v-75xmmedium6.1
NukeView CMS vulnerable to Cross-site Scripting
The advisory, in context
NukeView CMS has been found to be vulnerable to Cross-site Scripting. Affected by this issue is the function filterAttr of the file vendor/vinades/nukeviet/Core/Request.php of the component Data URL Handler. The manipulation of the argument attrSubSet leads to cross site scripting. The attack may be launched remotely. Upgrading to version 4.5 is able to address this issue. The name of the patch is 0b3197fad950bb3383e83039a8ee4c9509b3ce02. It is recommended to upgrade the affected component.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
nukeviet/nukeviet Packagist
Ecosystem versions
Earlier releases before 4.5
Fixed in 4.5
2 explicitly affected versions
4.0.24, 4.4.01
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "4.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.24",
"4.4.01"
]
}