Cross-site scripting in demos/demo.mysqli.php in getID3
Summary
The imported advisory is rated medium severity. It identifies 1 affected package; whether you are affected depends on your installed version. It is not listed in the imported CISA KEV data; that does not establish that exploitation has not occurred.
Summary by cve.new · CC BY 4.0Original source description
Cross-site scripting (XSS) vulnerability in demos/demo.mysqli.php in getID3 1.X and v2.0.0-beta allows remote attackers to inject arbitrary web script or HTML via the showtagfiles parameter.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 1.0.0 before 1.9.21
Fixed in 1.9.21
13 explicitly affected versions
v1.9.10, v1.9.11, v1.9.12, v1.9.13, v1.9.14, v1.9.15, v1.9.16, v1.9.17, v1.9.18, v1.9.19, v1.9.20, v1.9.8, v1.9.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.0.0"
},
{
"fixed": "1.9.21"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.9.10",
"v1.9.11",
"v1.9.12",
"v1.9.13",
"v1.9.14",
"v1.9.15",
"v1.9.16",
"v1.9.17",
"v1.9.18",
"v1.9.19",
"v1.9.20",
"v1.9.8",
"v1.9.9"
]
}