GHSA-wxxx-2x6v-979fmedium6.1
Reflected XSS in Zen Cart before 1.5.7a
The advisory, in context
Zen Cart 1.5.6d allows reflected XSS via the main_page parameter to includes/templates/template_default/common/tpl_main_page.php or includes/templates/responsive_classic/common/tpl_main_page.php.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
zencart/zencart Packagist
Ecosystem versions
Earlier releases before 1.5.7a
Fixed in 1.5.7a
4 explicitly affected versions
v1.5.6, v1.5.6a, v1.5.6b, v1.5.6b-2019-05-27
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.5.7a"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.5.6",
"v1.5.6a",
"v1.5.6b",
"v1.5.6b-2019-05-27"
]
}