Use of Cryptographically Weak Pseudo-Random Number Generator in yiisoft/yii2-dev
The advisory, in context
yii2 is vulnerable to Use of Predictable Algorithm in Random Number Generator
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 2.0.43
Fixed in 2.0.43
62 explicitly affected versions
2.0.0, 2.0.0-alpha, 2.0.0-beta, 2.0.0-rc, 2.0.1, 2.0.10, 2.0.11, 2.0.11.1, 2.0.11.2, 2.0.12, 2.0.12.1, 2.0.12.2, 2.0.13, 2.0.13.1, 2.0.13.2, 2.0.13.3, 2.0.14, 2.0.14.1, 2.0.14.2, 2.0.15, 2.0.15.1, 2.0.16, 2.0.16.1, 2.0.17, 2.0.18, 2.0.19, 2.0.2, 2.0.20, 2.0.21, 2.0.22, 2.0.23, 2.0.24, 2.0.25, 2.0.26, 2.0.27, 2.0.28, 2.0.29, 2.0.3, 2.0.30, 2.0.31, 2.0.32, 2.0.33, 2.0.34, 2.0.35, 2.0.36, 2.0.37, 2.0.38, 2.0.39, 2.0.39.1, 2.0.39.2, 2.0.39.3, 2.0.4, 2.0.40, 2.0.41, 2.0.41.1, 2.0.42, 2.0.42.1, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.43"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.0",
"2.0.0-alpha",
"2.0.0-beta",
"2.0.0-rc",
"2.0.1",
"2.0.10",
"2.0.11",
"2.0.11.1",
"2.0.11.2",
"2.0.12",
"2.0.12.1",
"2.0.12.2",
"2.0.13",
"2.0.13.1",
"2.0.13.2",
"2.0.13.3",
"2.0.14",
"2.0.14.1",
"2.0.14.2",
"2.0.15",
"2.0.15.1",
"2.0.16",
"2.0.16.1",
"2.0.17",
"2.0.18",
"2.0.19",
"2.0.2",
"2.0.20",
"2.0.21",
"2.0.22",
"2.0.23",
"2.0.24",
"2.0.25",
"2.0.26",
"2.0.27",
"2.0.28",
"2.0.29",
"2.0.3",
"2.0.30",
"2.0.31",
"2.0.32",
"2.0.33",
"2.0.34",
"2.0.35",
"2.0.36",
"2.0.37",
"2.0.38",
"2.0.39",
"2.0.39.1",
"2.0.39.2",
"2.0.39.3",
"2.0.4",
"2.0.40",
"2.0.41",
"2.0.41.1",
"2.0.42",
"2.0.42.1",
"2.0.5",
"2.0.6",
"2.0.7",
"2.0.8",
"2.0.9"
]
}