GHSA-ww3w-592j-5qrwmedium5.9
SimpleSAMLphp Incorrect IV generation for encryption
The advisory, in context
The aesEncrypt method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.x through 1.14.11 makes it easier for context-dependent attackers to bypass the encryption protection mechanism by leveraging use of the first 16 bytes of the secret key as the initialization vector (IV).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
simplesamlphp/simplesamlphp Packagist
Ecosystem versions
From 1.14.0 before 1.14.12
Fixed in 1.14.12
12 explicitly affected versions
v1.14.0, v1.14.1, v1.14.10, v1.14.11, v1.14.2, v1.14.3, v1.14.4, v1.14.5, v1.14.6, v1.14.7, v1.14.8, v1.14.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.14.0"
},
{
"fixed": "1.14.12"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.14.0",
"v1.14.1",
"v1.14.10",
"v1.14.11",
"v1.14.2",
"v1.14.3",
"v1.14.4",
"v1.14.5",
"v1.14.6",
"v1.14.7",
"v1.14.8",
"v1.14.9"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2017-12871
- https://github.com/simplesamlphp/simplesamlphp/commit/77df6a932d46daa35e364925eb73a175010dc904
- https://github.com/simplesamlphp/simplesamlphp/commit/ccf75981187aa88f7165abdb1b1965c0934acda0
- https://github.com/FriendsOfPHP/security-advisories/blob/master/simplesamlphp/simplesamlphp/CVE-2017-12871.yaml
- https://github.com/simplesamlphp/simplesamlphp
- https://simplesamlphp.org/security/201703-02