Cross-site Scripting in moodle
The advisory, in context
A flaw was found in moodle where ID numbers displayed when bulk allocating markers to assignments required additional sanitizing to prevent a stored XSS risk.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 4.0 before 4.0.1
Fixed in 4.0.1
6 explicitly affected versions
v4.0.0, v4.0.0-beta, v4.0.0-rc1, v4.0.0-rc2, v4.0.0-rc3, v4.0.0-rc4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0"
},
{
"fixed": "4.0.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.0.0",
"v4.0.0-beta",
"v4.0.0-rc1",
"v4.0.0-rc2",
"v4.0.0-rc3",
"v4.0.0-rc4"
]
}From 3.11 before 3.11.7
Fixed in 3.11.7
10 explicitly affected versions
v3.11.0, v3.11.0-beta, v3.11.0-rc1, v3.11.0-rc2, v3.11.1, v3.11.2, v3.11.3, v3.11.4, v3.11.5, v3.11.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.11"
},
{
"fixed": "3.11.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.11.0",
"v3.11.0-beta",
"v3.11.0-rc1",
"v3.11.0-rc2",
"v3.11.1",
"v3.11.2",
"v3.11.3",
"v3.11.4",
"v3.11.5",
"v3.11.6"
]
}From 3.10 before 3.10.11
Fixed in 3.10.11
14 explicitly affected versions
v3.10.0, v3.10.0-beta, v3.10.0-rc1, v3.10.0-rc2, v3.10.1, v3.10.10, v3.10.2, v3.10.3, v3.10.4, v3.10.5, v3.10.6, v3.10.7, v3.10.8, v3.10.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.10"
},
{
"fixed": "3.10.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.10.0",
"v3.10.0-beta",
"v3.10.0-rc1",
"v3.10.0-rc2",
"v3.10.1",
"v3.10.10",
"v3.10.2",
"v3.10.3",
"v3.10.4",
"v3.10.5",
"v3.10.6",
"v3.10.7",
"v3.10.8",
"v3.10.9"
]
}From 3.9 before 3.9.14
Fixed in 3.9.14
18 explicitly affected versions
v3.9.0, v3.9.0-beta, v3.9.0-rc1, v3.9.0-rc2, v3.9.0-rc3, v3.9.1, v3.9.10, v3.9.11, v3.9.12, v3.9.13, v3.9.2, v3.9.3, v3.9.4, v3.9.5, v3.9.6, v3.9.7, v3.9.8, v3.9.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.9"
},
{
"fixed": "3.9.14"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.9.0",
"v3.9.0-beta",
"v3.9.0-rc1",
"v3.9.0-rc2",
"v3.9.0-rc3",
"v3.9.1",
"v3.9.10",
"v3.9.11",
"v3.9.12",
"v3.9.13",
"v3.9.2",
"v3.9.3",
"v3.9.4",
"v3.9.5",
"v3.9.6",
"v3.9.7",
"v3.9.8",
"v3.9.9"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-30596
- https://github.com/moodle/moodle/commit/6abe964bbac41b5e40a81b40962f7044b0dc201e
- https://bugzilla.redhat.com/show_bug.cgi?id=2083583
- https://github.com/moodle/moodle
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/OGF35EN5K2R6X3NTY3XPZSJ3UDASMXI6
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PIMSIRKCFLIC646K4GMUSZU7THOUVPAJ
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QCTWSE3JDMSYL7DPCMXMMJEXZSS6VIA5
- https://moodle.org/mod/forum/discuss.php?d=434578
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-74204