Cross-site scripting vulnerabilities in old version of bundled TinyMCE
The advisory, in context
An old version of TinyMCE include an XSS vulnerability, which was patched in a later version. This was described by TinyMCE:
A cross-site scripting (XSS) vulnerability was discovered in the core parser. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.10 or lower and TinyMCE 5.4.0 or lower.
We reviewed the potential impact of this vulnerability within the context of Silverstripe CMS. We concluded this is a medium impact vulnerability given how TinyMCE is used by Silverstripe CMS.
Reported by: Developers at ACC
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 1.12.7
Fixed in 1.12.7
98 explicitly affected versions
1.0.0, 1.0.0-alpha6, 1.0.0-alpha7, 1.0.0-beta1, 1.0.0-beta2, 1.0.0-beta3, 1.0.0-beta4, 1.0.0-rc1, 1.0.0-rc2, 1.0.0-rc3, 1.0.1, 1.0.1-rc1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.1.0, 1.1.0-rc1, 1.1.0-rc2, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.10.0, 1.10.0-beta1, 1.10.0-rc1, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.11.0, 1.11.0-beta1, 1.11.0-rc1, 1.11.1, 1.11.2, 1.11.3, 1.12.0, 1.12.0-beta1, 1.12.0-rc1, 1.12.1, 1.12.2, 1.12.3, 1.12.4, 1.12.5, 1.12.6, 1.2.0, 1.2.0-beta1, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.3.0, 1.3.0-rc1, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.4.0, 1.4.0-rc1, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.5.0, 1.5.0-alpha1, 1.5.0-rc1, 1.5.0-rc2, 1.5.1, 1.5.2, 1.6.0, 1.6.0-beta1, 1.6.0-rc1, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.7.0, 1.7.0-beta1, 1.7.0-rc1, 1.7.1, 1.7.2, 1.7.3, 1.7.4, 1.8.0, 1.8.0-beta1, 1.8.0-rc1, 1.8.1, 1.9.0, 1.9.0-alpha1, 1.9.0-beta1, 1.9.0-rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.12.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.0",
"1.0.0-alpha6",
"1.0.0-alpha7",
"1.0.0-beta1",
"1.0.0-beta2",
"1.0.0-beta3",
"1.0.0-beta4",
"1.0.0-rc1",
"1.0.0-rc2",
"1.0.0-rc3",
"1.0.1",
"1.0.1-rc1",
"1.0.2",
"1.0.3",
"1.0.4",
"1.0.5",
"1.0.6",
"1.0.7",
"1.1.0",
"1.1.0-rc1",
"1.1.0-rc2",
"1.1.1",
"1.1.2",
"1.1.3",
"1.1.4",
"1.1.5",
"1.10.0",
"1.10.0-beta1",
"1.10.0-rc1",
"1.10.1",
"1.10.2",
"1.10.3",
"1.10.4",
"1.11.0",
"1.11.0-beta1",
"1.11.0-rc1",
"1.11.1",
"1.11.2",
"1.11.3",
"1.12.0",
"1.12.0-beta1",
"1.12.0-rc1",
"1.12.1",
"1.12.2",
"1.12.3",
"1.12.4",
"1.12.5",
"1.12.6",
"1.2.0",
"1.2.0-beta1",
"1.2.1",
"1.2.2",
"1.2.3",
"1.2.4",
"1.2.5",
"1.2.6",
"1.3.0",
"1.3.0-rc1",
"1.3.1",
"1.3.2",
"1.3.3",
"1.3.4",
"1.3.5",
"1.4.0",
"1.4.0-rc1",
"1.4.1",
"1.4.2",
"1.4.3",
"1.4.4",
"1.4.5",
"1.5.0",
"1.5.0-alpha1",
"1.5.0-rc1",
"1.5.0-rc2",
"1.5.1",
"1.5.2",
"1.6.0",
"1.6.0-beta1",
"1.6.0-rc1",
"1.6.1",
"1.6.2",
"1.6.3",
"1.6.4",
"1.7.0",
"1.7.0-beta1",
"1.7.0-rc1",
"1.7.1",
"1.7.2",
"1.7.3",
"1.7.4",
"1.8.0",
"1.8.0-beta1",
"1.8.0-rc1",
"1.8.1",
"1.9.0",
"1.9.0-alpha1",
"1.9.0-beta1",
"1.9.0-rc1"
]
}References
- https://github.com/silverstripe/silverstripe-admin/security/advisories/GHSA-wqm8-jx8r-8rcq
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/admin/SS-2023-001.yaml
- https://github.com/advisories/GHSA-vrv8-v4w8-f95h
- https://github.com/silverstripe/silverstripe-admin
- https://www.silverstripe.org/download/security-releases/ss-2023-001
- https://www.tiny.cloud/docs/release-notes/release-notes54/#securityfixes