contao/core PHP object injection vulnerability allows for arbitrary code execution
The advisory, in context
PHP object injection vulnerability was identified in contao/core due to untrusted data being passed to deserialize() function.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 2.0.0 before 2.11.14
Fixed in 2.11.14
54 explicitly affected versions
2.10.0, 2.10.1, 2.10.2, 2.10.3, 2.10.4, 2.10.RC1, 2.10.beta1, 2.11.0, 2.11.1, 2.11.10, 2.11.11, 2.11.12, 2.11.13, 2.11.2, 2.11.3, 2.11.4, 2.11.5, 2.11.6, 2.11.7, 2.11.8, 2.11.9, 2.11.RC1, 2.11.RC2, 2.6.0, 2.6.1, 2.6.2, 2.6.3, 2.6.4, 2.6.5, 2.6.6, 2.6.7, 2.6.8, 2.7.0, 2.7.1, 2.7.2, 2.7.3, 2.7.4, 2.7.5, 2.7.6, 2.7.7, 2.8.0, 2.8.1, 2.8.2, 2.8.3, 2.8.4, 2.8.RC1, 2.8.RC2, 2.9.0, 2.9.1, 2.9.2, 2.9.3, 2.9.4, 2.9.5, 2.9.RC1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.11.14"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.10.0",
"2.10.1",
"2.10.2",
"2.10.3",
"2.10.4",
"2.10.RC1",
"2.10.beta1",
"2.11.0",
"2.11.1",
"2.11.10",
"2.11.11",
"2.11.12",
"2.11.13",
"2.11.2",
"2.11.3",
"2.11.4",
"2.11.5",
"2.11.6",
"2.11.7",
"2.11.8",
"2.11.9",
"2.11.RC1",
"2.11.RC2",
"2.6.0",
"2.6.1",
"2.6.2",
"2.6.3",
"2.6.4",
"2.6.5",
"2.6.6",
"2.6.7",
"2.6.8",
"2.7.0",
"2.7.1",
"2.7.2",
"2.7.3",
"2.7.4",
"2.7.5",
"2.7.6",
"2.7.7",
"2.8.0",
"2.8.1",
"2.8.2",
"2.8.3",
"2.8.4",
"2.8.RC1",
"2.8.RC2",
"2.9.0",
"2.9.1",
"2.9.2",
"2.9.3",
"2.9.4",
"2.9.5",
"2.9.RC1"
]
}From 3.0.0 before 3.2.5
Fixed in 3.2.5
23 explicitly affected versions
3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.1.0, 3.1.1, 3.1.2, 3.1.3, 3.1.4, 3.1.5, 3.1.RC1, 3.1.beta1, 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.2.4, 3.2.RC1, 3.2.beta1, 3.2.beta2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.2.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.0.0",
"3.0.1",
"3.0.2",
"3.0.3",
"3.0.4",
"3.0.5",
"3.0.6",
"3.1.0",
"3.1.1",
"3.1.2",
"3.1.3",
"3.1.4",
"3.1.5",
"3.1.RC1",
"3.1.beta1",
"3.2.0",
"3.2.1",
"3.2.2",
"3.2.3",
"3.2.4",
"3.2.RC1",
"3.2.beta1",
"3.2.beta2"
]
}References
- https://github.com/contao/core/issues/6695
- https://github.com/contao/core/commit/d67c46c1f1283134e3050244cfdda0ef26fa5cd4
- https://github.com/contao/core/commit/f939b5be8a0048ef779def3289e2072febef1b37
- https://contao.org/en/news/major-security-hole-found-in-contao.html
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/core/2014-02-13.yaml