GHSA-wpfp-q843-v772medium6.1
Cross-site Scripting in moodle
The advisory, in context
A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A URL parameter in the filetype site administrator tool required extra sanitizing to prevent a reflected XSS risk.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 3.11.0 before 3.11.4
Fixed in 3.11.4
4 explicitly affected versions
v3.11.0, v3.11.1, v3.11.2, v3.11.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.11.0"
},
{
"fixed": "3.11.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.11.0",
"v3.11.1",
"v3.11.2",
"v3.11.3"
]
}moodle/moodle Packagist
Ecosystem versions
From 3.10.0 before 3.10.8
Fixed in 3.10.8
8 explicitly affected versions
v3.10.0, v3.10.1, v3.10.2, v3.10.3, v3.10.4, v3.10.5, v3.10.6, v3.10.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.10.0"
},
{
"fixed": "3.10.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.10.0",
"v3.10.1",
"v3.10.2",
"v3.10.3",
"v3.10.4",
"v3.10.5",
"v3.10.6",
"v3.10.7"
]
}moodle/moodle Packagist
Ecosystem versions
From 3.9.0 before 3.9.11
Fixed in 3.9.11
11 explicitly affected versions
v3.9.0, v3.9.1, v3.9.10, v3.9.2, v3.9.3, v3.9.4, v3.9.5, v3.9.6, v3.9.7, v3.9.8, v3.9.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.9.0"
},
{
"fixed": "3.9.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.9.0",
"v3.9.1",
"v3.9.10",
"v3.9.2",
"v3.9.3",
"v3.9.4",
"v3.9.5",
"v3.9.6",
"v3.9.7",
"v3.9.8",
"v3.9.9"
]
}