GHSA-wm86-w3cf-h6vmmedium4.7
Drupal external link injection vulnerability
The advisory, in context
Drupal core 7.x versions before 7.57 has an external link injection vulnerability when the language switcher block is used. A similar vulnerability exists in various custom and contributed modules. This vulnerability could allow an attacker to trick users into unwillingly navigating to an external site.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
drupal/core Packagist
Ecosystem versions
From 7.0 before 7.57
Fixed in 7.57
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.0"
},
{
"fixed": "7.57"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}drupal/drupal Packagist
Ecosystem versions
From 7.0 before 7.57
Fixed in 7.57
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.0"
},
{
"fixed": "7.57"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2017-6932
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2017-6932.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2017-6932.yaml
- https://github.com/drupal/core
- https://lists.debian.org/debian-lts-announce/2018/02/msg00030.html
- https://www.debian.org/security/2018/dsa-4123
- https://www.drupal.org/sa-core-2018-001